summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/ibam/ibam-0.4.ebuild')
-rw-r--r--app-laptop/ibam/ibam-0.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-laptop/ibam/ibam-0.4.ebuild b/app-laptop/ibam/ibam-0.4.ebuild
new file mode 100644
index 000000000000..7e944be83478
--- /dev/null
+++ b/app-laptop/ibam/ibam-0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/ibam/ibam-0.4.ebuild,v 1.1 2006/01/15 14:29:41 brix Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Intelligent Battery Monitor"
+HOMEPAGE="http://ibam.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND="sys-apps/sed"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i \
+ -e "s:^CFLAGS=-O3:CFLAGS=${CFLAGS}:" \
+ -e "s:^CC=g++:CC=$(tc-getCXX):" \
+ ${S}/Makefile
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin ibam
+
+ dodoc CHANGES README REPORT
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You will need to install media-gfx/gnuplot if you wish to use"
+ einfo "the --plot argument to ibam."
+ einfo
+}