summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/boxes')
-rw-r--r--app-misc/boxes/boxes-1.0.1.ebuild33
-rw-r--r--app-misc/boxes/files/boxes-1.0.1-gentoo.diff24
-rw-r--r--app-misc/boxes/files/digest-boxes-1.0.11
3 files changed, 58 insertions, 0 deletions
diff --git a/app-misc/boxes/boxes-1.0.1.ebuild b/app-misc/boxes/boxes-1.0.1.ebuild
new file mode 100644
index 000000000000..da1a81bc75d2
--- /dev/null
+++ b/app-misc/boxes/boxes-1.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Michael Conrad Tilstra <michael@gentoo.org> <tadpol@tadpol.org>
+# $Header: /var/cvsroot/gentoo-x86/app-misc/boxes/boxes-1.0.1.ebuild,v 1.1 2001/05/20 21:44:39 michael Exp $
+
+A=${P}.src.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="boxes draws any kind of boxes around your text!"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/utils/text/${A}"
+HOMEPAGE="http://www6.informatik.uni-erlangen.de/~tsjensen/boxes/"
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ try patch -p1 < ${FILESDIR}/${P}-gentoo.diff
+}
+
+
+src_compile() {
+ try make clean
+ try make
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1 /usr/share/boxes
+ dobin src/boxes
+ doman doc/boxes.1
+ dodoc README COPYING
+ insinto /usr/share/boxes
+ doins boxes-config
+}
+
diff --git a/app-misc/boxes/files/boxes-1.0.1-gentoo.diff b/app-misc/boxes/files/boxes-1.0.1-gentoo.diff
new file mode 100644
index 000000000000..16330205cbdf
--- /dev/null
+++ b/app-misc/boxes/files/boxes-1.0.1-gentoo.diff
@@ -0,0 +1,24 @@
+diff -ru boxes-1.0.1.orig/Makefile boxes-1.0.1/Makefile
+--- boxes-1.0.1.orig/Makefile Sun May 20 16:19:18 2001
++++ boxes-1.0.1/Makefile Sun May 20 16:19:39 2001
+@@ -51,7 +51,7 @@
+
+
+ # The following line (GLOBALCONF) is the only line you should need to edit!
+-GLOBALCONF = /usr/local/share/boxes
++GLOBALCONF = /usr/share/boxes/boxes-config
+ BVERSION = 1.0.1
+
+ SNAPFILE = boxes-SNAP-$(shell date +%Y%m%d)
+diff -ru boxes-1.0.1.orig/src/regexp/Makefile boxes-1.0.1/src/regexp/Makefile
+--- boxes-1.0.1.orig/src/regexp/Makefile Sun May 20 16:19:18 2001
++++ boxes-1.0.1/src/regexp/Makefile Sun May 20 16:21:01 2001
+@@ -32,7 +32,7 @@
+ #============================================================================
+
+
+-CFLAGS = -traditional -O -I. $(CFLAGS_ADDTL)
++CFLAGS = -O -I. $(CFLAGS_ADDTL)
+
+ ALL_CL = regexp/regexp.c regexp/regsub.c
+ C_SRC = $(notdir $(ALL_CL))
diff --git a/app-misc/boxes/files/digest-boxes-1.0.1 b/app-misc/boxes/files/digest-boxes-1.0.1
new file mode 100644
index 000000000000..977333fb642b
--- /dev/null
+++ b/app-misc/boxes/files/digest-boxes-1.0.1
@@ -0,0 +1 @@
+MD5 77935fb3b566755db798d678f945bd4d boxes-1.0.1.src.tar.gz