summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/cdspeed/cdspeed-0.4.ebuild')
-rw-r--r--app-misc/cdspeed/cdspeed-0.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/cdspeed/cdspeed-0.4.ebuild b/app-misc/cdspeed/cdspeed-0.4.ebuild
new file mode 100644
index 000000000000..f61df46458db
--- /dev/null
+++ b/app-misc/cdspeed/cdspeed-0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cdspeed/cdspeed-0.4.ebuild,v 1.1 2005/02/12 10:12:22 kloeri Exp $
+
+DESCRIPTION="Change the speed of your CD drive"
+HOMEPAGE="http://linuxfocus.org/~guido/"
+SRC_URI="http://linuxfocus.org/~guido/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64"
+IUSE=""
+
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e 's:^CFLAGS=.*:CFLAGS=$(E_CFLAGS):' \
+ Makefile || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake E_CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin cdspeed || die "dobin failed"
+ exeinto /usr/lib/cdspeed
+ doexe cdmount || die "doexe failed"
+ dodoc README
+}