summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/gcal/gcal-3.01-r2.ebuild')
-rw-r--r--app-misc/gcal/gcal-3.01-r2.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/app-misc/gcal/gcal-3.01-r2.ebuild b/app-misc/gcal/gcal-3.01-r2.ebuild
index 6c63b0e60c93..99824f4e3c89 100644
--- a/app-misc/gcal/gcal-3.01-r2.ebuild
+++ b/app-misc/gcal/gcal-3.01-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gcal/gcal-3.01-r2.ebuild,v 1.12 2008/02/03 17:40:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gcal/gcal-3.01-r2.ebuild,v 1.13 2008/09/17 10:12:51 pva Exp $
-inherit eutils
+inherit eutils flag-o-matic toolchain-funcs
DESCRIPTION="The GNU Calendar - a replacement for cal"
HOMEPAGE="http://www.gnu.org/software/gcal/gcal.html"
@@ -17,27 +17,31 @@ DEPEND="nls? ( sys-devel/gettext )"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-mandir.diff
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-mandir.diff
+ find -name Makefile.in -print0 | \
+ xargs -0 -n1 sed -i "s:\(^CC = \).*:\1$(tc-getCC):"
}
src_compile() {
- econf $(use_enable nls) $(use_enable ncurses) || die
+ append-flags -D_GNU_SOURCE
+ econf $(use_enable nls) $(use_enable ncurses)
emake || die
}
src_install() {
einstall || die
- rm -f ${D}/usr/share/locale/locale.alias
+ rm -f "${D}"/usr/share/locale/locale.alias
- dodoc ABOUT-NLS ATTENTION BUGS DISCLAIM HISTORY \
- INSTALL LIMITATIONS MANIFEST NEWS README SYMBOLS THANKS TODO
+ dodoc ATTENTION BUGS DISCLAIM HISTORY LIMITATIONS MANIFEST NEWS README \
+ SYMBOLS THANKS TODO
# Need to fix up paths for scripts in misc directory
# that are automatically created by the makefile
- for miscfile in ${D}/usr/share/gcal/misc/*/*
+ for miscfile in "${D}"/usr/share/gcal/misc/*/*
do
- dosed "s:${D%/}::g" ${miscfile/${D}}
+ dosed "s:${D%/}::g" "${miscfile/${D}}"
done
# Rebuild the symlinks that makefile created into the image /usr/bin