summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/omnibook/omnibook-20030828.ebuild')
-rw-r--r--app-misc/omnibook/omnibook-20030828.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/omnibook/omnibook-20030828.ebuild b/app-misc/omnibook/omnibook-20030828.ebuild
new file mode 100644
index 000000000000..585a8f63c39e
--- /dev/null
+++ b/app-misc/omnibook/omnibook-20030828.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/omnibook/omnibook-20030828.ebuild,v 1.1 2003/10/31 22:32:15 plasmaroo Exp $
+
+MY_PV="2003-08-28"
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Linux kernel module for HP Omnibook support"
+HOMEPAGE="http://www.sourceforge.net/projects/omke"
+SRC_URI="mirror://sourceforge/omke/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="virtual/kernel"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake CC="gcc ${CFLAGS}" || die
+}
+
+src_install() {
+ # The driver goes into the standard modules location
+ # Not the make install location, because that way it would get deleted
+ # when the user did a make modules_install in the Kernel tree
+
+ insinto /lib/modules/${KV}/char
+ doins omnibook.o
+
+ dodoc ${S}/doc/*
+
+}
+
+pkg_postinst() {
+ echo "running depmod...."
+ depmod -aq || die
+}