summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/rio/rio-1.0.7-r1.ebuild')
-rw-r--r--app-misc/rio/rio-1.0.7-r1.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/app-misc/rio/rio-1.0.7-r1.ebuild b/app-misc/rio/rio-1.0.7-r1.ebuild
index 63662ccd70f3..469277bab711 100644
--- a/app-misc/rio/rio-1.0.7-r1.ebuild
+++ b/app-misc/rio/rio-1.0.7-r1.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/rio/rio-1.0.7-r1.ebuild,v 1.1 2005/08/20 03:07:11 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rio/rio-1.0.7-r1.ebuild,v 1.2 2007/12/25 14:47:53 drac Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Utility for the Diamond Rio 300 portable MP3 player"
HOMEPAGE="http://www.world.co.uk/sba/rio.html"
SRC_URI="http://www.world.co.uk/sba/${PN}007.tgz"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
SLOT="0"
LICENSE="GPL-2"
IUSE=""
@@ -19,16 +19,18 @@ RDEPEND=""
S="${WORKDIR}/${PN}${PV//./}"
src_unpack() {
- unpack ${A}; cd ${S}
- epatch ${FILESDIR}/${P}-makefile.patch
- epatch ${FILESDIR}/${P}-gentoo.patch
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-includes.patch
}
src_compile() {
- emake || die "compile failed"
+ emake CXX="$(tc-getCXX)" || die "emake failed."
}
src_install() {
- dobin rio || die
- dodoc CREDITS README gpl.txt playlist.txt rio.txt
+ dobin rio
+ dodoc CREDITS README playlist.txt rio.txt
}