summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/sl/ChangeLog11
-rw-r--r--app-misc/sl/files/Makefile.patch29
-rw-r--r--app-misc/sl/files/fix_compilation.patch22
-rw-r--r--app-misc/sl/sl-3.03-r1.ebuild54
4 files changed, 115 insertions, 1 deletions
diff --git a/app-misc/sl/ChangeLog b/app-misc/sl/ChangeLog
index 47d28fb6a457..0d37fd0461e8 100644
--- a/app-misc/sl/ChangeLog
+++ b/app-misc/sl/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-misc/sl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sl/ChangeLog,v 1.15 2010/01/01 21:21:21 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sl/ChangeLog,v 1.16 2010/08/09 20:34:19 idl0r Exp $
+
+*sl-3.03-r1 (09 Aug 2010)
+
+ 09 Aug 2010; Christian Ruppert <idl0r@gentoo.org> +sl-3.03-r1.ebuild,
+ +files/Makefile.patch, +files/fix_compilation.patch:
+ Revision bump. Add Makefile patch to allow the use of the Makefile. Add
+ patch to fix compiler warnings. Fix HOMEPAGE. Use EAPI 3, some QA fixes
+ and clean up. Thanks to Diego E. 'Flameeyes' Pettenò
+ <flameeyes@gentoo.org> for the calloc hint.
01 Jan 2010; Christian Faulhammer <fauli@gentoo.org> sl-3.03.ebuild:
Transfer Prefix keywords
diff --git a/app-misc/sl/files/Makefile.patch b/app-misc/sl/files/Makefile.patch
new file mode 100644
index 000000000000..2591c4de45f1
--- /dev/null
+++ b/app-misc/sl/files/Makefile.patch
@@ -0,0 +1,29 @@
+--- sl.orig/Makefile 2010-08-09 21:36:45.483225339 +0200
++++ sl/Makefile 2010-08-09 21:58:23.915058929 +0200
+@@ -5,13 +5,13 @@
+ # Last Modified: 1998/ 7/22
+ #==========================================
+
+-CC = gcc
++CC ?= gcc
+
+ #DEBUGOPTS = -DDEBUG -g
+
+ # For Linux 2.0.x
+-LDFLAGS = -lncurses -ltermcap
+-CFLAGS = -Wall -O2 -DLINUX20 $(DEBUGOPTS)
++LDLIBS = -lncurses
++CFLAGS ?= -Wall -O2 $(DEBUGOPTS)
+
+ # For Solaris
+ #LDFLAGS = -lcurses -ltermcap
+@@ -19,8 +19,7 @@ CFLAGS = -Wall -O2 -DLINUX20 $(DEBUGOPTS
+
+ all: sl
+
+-sl: sl.c sl.h header.h Makefile
+- $(CC) $(CFLAGS) -o sl sl.c $(LDFLAGS)
++sl: sl.o
+
+ clean:
+ -rm -f sl sl.o core
diff --git a/app-misc/sl/files/fix_compilation.patch b/app-misc/sl/files/fix_compilation.patch
new file mode 100644
index 000000000000..5b63a844f9f5
--- /dev/null
+++ b/app-misc/sl/files/fix_compilation.patch
@@ -0,0 +1,22 @@
+--- sl.orig/sl.c 2010-08-09 21:36:45.483225339 +0200
++++ sl/sl.c 2010-08-09 22:01:12.462051982 +0200
+@@ -30,6 +30,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <strings.h>
++#include <string.h>
+ #include <time.h>
+ #ifdef LINUX20
+ #include <ncurses/curses.h>
+@@ -186,10 +187,7 @@ int main(int argc, char *argv[])
+ scrollok(stdscr, FALSE);
+ DIREC = RTOL;
+ p = 3 * COLS / 10;
+- pp = (char*)malloc((size_t)(COLS + ALL_LENGTH + 10) * (D51HIGHT + 1) * (D51PATTERNS + 1));
+- for (i = 0; i <= (COLS + ALL_LENGTH + 1) * (D51HIGHT + 1) * D51PATTERNS; ++i) {
+- pp[i] = (char)NULL;
+- }
++ pp = (char *)calloc(1, (size_t)(COLS + ALL_LENGTH + 10) * (D51HIGHT + 1) * (D51PATTERNS + 1));
+
+ for (j = 0; j < D51PATTERNS; ++j) {
+ for (i = 0; i <= D51HIGHT; ++i) {
diff --git a/app-misc/sl/sl-3.03-r1.ebuild b/app-misc/sl/sl-3.03-r1.ebuild
new file mode 100644
index 000000000000..deaeffac6262
--- /dev/null
+++ b/app-misc/sl/sl-3.03-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sl/sl-3.03-r1.ebuild,v 1.1 2010/08/09 20:34:19 idl0r Exp $
+
+EAPI=3
+
+inherit eutils toolchain-funcs flag-o-matic
+
+SL_PATCH="sl5-1.patch"
+
+DESCRIPTION="sophisticated graphical program which corrects your miss typing"
+HOMEPAGE="http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/ http://www.izumix.org.uk/sl/"
+SRC_URI="http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/sl/${PN}.tar
+ http://www.linet.gr.jp/~izumi/sl/${SL_PATCH}
+ http://www.sodan.ecc.u-tokyo.ac.jp/~okayama/sl/${PN}.en.1.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="linguas_ja debug"
+
+DEPEND="sys-libs/ncurses"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${DISTDIR}/${SL_PATCH}"
+ epatch "${FILESDIR}/${P}-gentoo.diff"
+ epatch "${FILESDIR}/Makefile.patch"
+ epatch "${FILESDIR}/fix_compilation.patch"
+}
+
+src_compile() {
+ use debug && append-flags -DDEBUG
+
+ emake CC=$(tc-getCC) || die
+
+ if use linguas_ja; then
+ iconv -f ISO-2022-JP -t EUC-JP sl.1 > sl.ja.1
+ fi
+}
+
+src_install() {
+ dobin sl || die
+
+ newman "${WORKDIR}/sl.en.1" sl.1
+ dodoc sl.txt
+
+ if use linguas_ja ; then
+ dodoc README*
+ insinto /usr/share/man/ja/man1
+ newins sl.ja.1 sl.1
+ fi
+}