summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/gammu/files/gammu-1.12.0-fixups.patch')
-rw-r--r--app-mobilephone/gammu/files/gammu-1.12.0-fixups.patch81
1 files changed, 81 insertions, 0 deletions
diff --git a/app-mobilephone/gammu/files/gammu-1.12.0-fixups.patch b/app-mobilephone/gammu/files/gammu-1.12.0-fixups.patch
new file mode 100644
index 000000000000..8d50feb92eac
--- /dev/null
+++ b/app-mobilephone/gammu/files/gammu-1.12.0-fixups.patch
@@ -0,0 +1,81 @@
+diff -Nru gammu-1.12.0.orig/CMakeLists.txt gammu-1.12.0/CMakeLists.txt
+--- gammu-1.12.0.orig/CMakeLists.txt 2007-06-12 13:30:30.000000000 +0300
++++ gammu-1.12.0/CMakeLists.txt 2007-07-01 12:12:07.000000000 +0300
+@@ -688,7 +688,7 @@
+
+ install (
+ FILES "${Gammu_BINARY_DIR}/cfg/gammu.pc"
+- DESTINATION "lib/pkgconfig"
++ DESTINATION "${INSTALL_LIB_DIR}/pkgconfig"
+ COMPONENT "development"
+ )
+
+diff -Nru gammu-1.12.0.orig/common/phone/nokia/dct4s40/6510/6510file.c gammu-1.12.0/common/phone/nokia/dct4s40/6510/6510file.c
+--- gammu-1.12.0.orig/common/phone/nokia/dct4s40/6510/6510file.c 2007-07-01 12:12:34.000000000 +0300
++++ gammu-1.12.0/common/phone/nokia/dct4s40/6510/6510file.c 2007-07-01 12:01:19.000000000 +0300
+@@ -934,7 +934,7 @@
+ msg.Buffer[11]*256*256+
+ msg.Buffer[12]*256+
+ msg.Buffer[13];
+- smprintf(s,"Size %i bytes\n",File->Used);
++ smprintf(s,"Size %zi bytes\n",File->Used);
+ }
+ File->ReadOnly = false;
+ if ((msg.Buffer[29] & 1) == 1) {
+diff -Nru gammu-1.12.0.orig/gammu/gammu.c gammu-1.12.0/gammu/gammu.c
+--- gammu-1.12.0.orig/gammu/gammu.c 2007-07-01 12:12:34.000000000 +0300
++++ gammu-1.12.0/gammu/gammu.c 2007-07-01 12:01:19.000000000 +0300
+@@ -2697,7 +2697,7 @@
+ error = GSM_GetFilePart(s,&File,&Handle,&Size);
+ if (error == ERR_EMPTY) break;
+ Print_Error(error);
+- fprintf(stderr, _("%c Reading: %i percent"),13,File.Used*100/Size);
++ fprintf(stderr, _("%c Reading: %i percent"),13, (int)(File.Used*100/Size));
+ }
+ fprintf(stderr, "%c",13);
+
+@@ -8289,7 +8289,7 @@
+ if (!Files.ModifiedEmpty) {
+ printf(" %30s",OSDateTime(Files.Modified,false));
+ } else printf(" %30c",0x20);
+- printf(" %9i",Files.Used);
++ printf(" %9zi",Files.Used);
+ printf(" ");
+ } else printf("|-- ");
+ } else {
+@@ -8325,7 +8325,7 @@
+ if (!Files.ModifiedEmpty) {
+ printf("\"%s\";",OSDateTime(Files.Modified,false));
+ } else printf("\"%c\";",0x20);
+- printf("%i;",Files.Used);
++ printf("%zi;",Files.Used);
+ } else {
+ if (error == ERR_FOLDERPART) {
+ printf(_("Part of folder;"));
+@@ -8440,7 +8440,7 @@
+ if (!Files.ModifiedEmpty) {
+ printf("\"%s\";",OSDateTime(Files.Modified,false));
+ } else printf("\"%c\";",0x20);
+- printf("%i;",Files.Used);
++ printf("%zi;",Files.Used);
+ } else {
+ printf(_("Folder"));
+ printf(";\"%s\";",DecodeUnicodeConsole(Files.Name));
+@@ -8495,7 +8495,7 @@
+ if (Size==0) {
+ printf("*");
+ } else {
+- fprintf(stderr, _("%c %i percent"), 13, File->Used*100/Size);
++ fprintf(stderr, _("%c %i percent"), 13, (int)(File->Used*100/Size));
+ if (File->Used*100/Size >= 2) {
+ t_time2 = time(NULL);
+ diff = t_time2-t_time1;
+@@ -8676,7 +8676,7 @@
+ if (File->Used != 0) {
+ fprintf(stderr, "\r");
+ fprintf(stderr, "%s", text);
+- fprintf(stderr, _("%3i percent"), Pos * 100 / File->Used);
++ fprintf(stderr, _("%3i percent"), (int)(Pos * 100 / File->Used));
+ if (Pos*100/File->Used >= 2) {
+ GSM_GetCurrentDateTime(&dt);
+ t_time2 = Fill_Time_T(dt);