summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/kexi/kexi-1.4.1.ebuild')
-rw-r--r--app-office/kexi/kexi-1.4.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-office/kexi/kexi-1.4.1.ebuild b/app-office/kexi/kexi-1.4.1.ebuild
new file mode 100644
index 000000000000..a9ff7ec5a983
--- /dev/null
+++ b/app-office/kexi/kexi-1.4.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/kexi-1.4.1.ebuild,v 1.1 2005/07/25 20:20:11 greg_g Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice integrated environment for database management."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="mysql postgres"
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ sys-libs/readline
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-libs/libpqxx )
+ dev-lang/python
+ !dev-db/kexi"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkoscript lib/koscript
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store"
+
+KMEXTRACTONLY="lib/"
+
+need-kde 3.3
+
+src_compile() {
+ local myconf="$(use_enable mysql) $(use_enable postgres pgsql)"
+
+ kde-meta_src_compile
+}