summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/koffice/koffice-1.2.1-r1.ebuild')
-rw-r--r--app-office/koffice/koffice-1.2.1-r1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/app-office/koffice/koffice-1.2.1-r1.ebuild b/app-office/koffice/koffice-1.2.1-r1.ebuild
index f9925b9c90db..2bf2a086af40 100644
--- a/app-office/koffice/koffice-1.2.1-r1.ebuild
+++ b/app-office/koffice/koffice-1.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.2.1-r1.ebuild,v 1.9 2004/04/20 15:48:26 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.2.1-r1.ebuild,v 1.10 2004/04/23 00:28:27 caleb Exp $
inherit kde-base flag-o-matic
filter-flags "-fomit-frame-pointer"
@@ -21,8 +21,11 @@ DEPEND="$DEPEND
PATCHES="$FILESDIR/${P}-kword-crashes.diff"
-export LIBPYTHON="`python-config --libs`"
-export LIBPYTHON="${LIBPYTHON//-L \/usr\/lib\/python2.2\/config}"
+src_compile() {
+ export LIBPYTHON="`python-config --libs`"
+ export LIBPYTHON="${LIBPYTHON//-L \/usr\/lib\/python2.2\/config}"
+ kde_src_compile
+}
export WANT_AUTOCONF=2.5
export WANT_AUTOMAKE=1.5