summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/libreoffice/files/gentoo-3.3.1.diff')
-rw-r--r--app-office/libreoffice/files/gentoo-3.3.1.diff68
1 files changed, 68 insertions, 0 deletions
diff --git a/app-office/libreoffice/files/gentoo-3.3.1.diff b/app-office/libreoffice/files/gentoo-3.3.1.diff
new file mode 100644
index 000000000000..8f0bcc167255
--- /dev/null
+++ b/app-office/libreoffice/files/gentoo-3.3.1.diff
@@ -0,0 +1,68 @@
+--- distro-configs/Gentoo.conf.in
++++ distro-configs/Gentoo.conf.in
+@@ -1,5 +1,3 @@
+---disable-fontooo
+---disable-qadevooo
+ --enable-neon
+ --enable-xrender-link
+ --with-external-dict-dir=/usr/share/myspell
+--- patches/dev300/apply
++++ patches/dev300/apply
+@@ -1687,16 +1687,8 @@
+ [ GentooOnly ]
+ SectionOwner => aprosky
+
+-# Allow build to proceed with PaX enabled
+-gentoo-pax-fix.diff, aprosky
+ # support server-only versions of 64bit JDKs
+ 64bit-jdk-server-paths.diff, i#65974, hmth
+-# use IBM j9vm over IBM classic JVM
+-ibm-j9vm.diff, hmth
+-# system db check
+-system-db-check.diff, i#65979, hmth
+-# User ~/.ooo3 as user dir
+-scp2-user-config-ooo3.diff, pmladek
+ # default inc/lib
+ config_office-XINC-XLIB-defaults.diff, i#65976
+ # Sandbox problem with wrong path
+--- configure.in
++++ configure.in
+@@ -1326,12 +1326,18 @@
+ done
+ fi
+ SUNTEMPLATES_LANG=
+- # check whether the langs are requested at all
+- for lang in $wanted_sun_templates ; do
+- if test -n "`echo $with_lang | grep "$lang"`" ; then
+- SUNTEMPLATES_LANG="$SUNTEMPLATES_LANG $lang"
+- fi
+- done
++
++ # --with-lang="" now used for en-US
++ if test "z$with_lang" = "z" ; then
++ SUNTEMPLATES_LANG="en-US"
++ else
++ # check whether the langs are requested at all
++ for lang in $wanted_sun_templates ; do
++ if test -n "`echo $with_lang | grep "$lang"`" ; then
++ SUNTEMPLATES_LANG="$SUNTEMPLATES_LANG $lang"
++ fi
++ done
++ fi
+ AC_MSG_RESULT([$SUNTEMPLATES_LANG])
+ fi
+ AC_SUBST(SUNTEMPLATES_LANG)
+--- bin/package-ooo
++++ bin/package-ooo
+@@ -126,8 +126,8 @@
+ fi
+
+ # create bash completion
+-mkdir -p $OODESTDIR/etc/bash_completion.d
+-$TOOLSDIR/bin/generate-bash-completion --binsuffix="$BINSUFFIX" $TOOLSDIR/bin/bash-completion.in $OODESTDIR/etc/bash_completion.d/libreoffice${BINSUFFIX}.sh
++mkdir -p $SYSCONFDIR/bash_completion.d
++$TOOLSDIR/bin/generate-bash-completion --binsuffix="$BINSUFFIX" $TOOLSDIR/bin/bash-completion.in $SYSCONFDIR/bash_completion.d/libreoffice${BINSUFFIX}.sh
+ if test "$COMPAT_OOWRAPPERS" = "YES" ; then
+ $TOOLSDIR/bin/generate-bash-completion --compat-oowrappers --binsuffix="$BINSUFFIX" $TOOLSDIR/bin/bash-completion.in $OODESTDIR/etc/bash_completion.d/ooffice${BINSUFFIX}.sh
+ fi
+