summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/tpp/files/tpp-1.3-Makefile.patch')
-rw-r--r--app-office/tpp/files/tpp-1.3-Makefile.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-office/tpp/files/tpp-1.3-Makefile.patch b/app-office/tpp/files/tpp-1.3-Makefile.patch
new file mode 100644
index 000000000000..34b7bf4dfde1
--- /dev/null
+++ b/app-office/tpp/files/tpp-1.3-Makefile.patch
@@ -0,0 +1,28 @@
+diff -urN tpp-1.3.orig/Makefile tpp-1.3/Makefile
+--- tpp-1.3.orig/Makefile 2005-06-12 04:39:10.000000000 -0700
++++ tpp-1.3/Makefile 2005-07-12 03:46:05.000000000 -0700
+@@ -3,10 +3,10 @@
+ #################################################
+
+ BIN = tpp
+-prefix=/usr/local
+-INSPATH= $(prefix)/bin/
+-DOCPATH = $(prefix)/share/doc/tpp
+-MANPATH = $(prefix)/share/man/man1
++prefix=/usr
++INSPATH= $(DESTDIR)$(prefix)/bin/
++DOCPATH = $(DESTDIR)$(prefix)/share/doc/tpp
++MANPATH = $(DESTDIR)$(prefix)/share/man/man1
+
+ all:
+ @echo "TPP doesn't need to be built. Run \`make install' in order to install it."
+@@ -14,7 +14,9 @@
+ install :
+ mkdir -p $(DOCPATH)
+ install -m644 DESIGN CHANGES COPYING README THANKS $(DOCPATH)
++ mkdir -p $(MANPATH)
+ install -m644 doc/tpp.1 $(MANPATH)
++ mkdir -p $(INSPATH)
+ install tpp.rb $(INSPATH)$(BIN)
+ mkdir -p $(DOCPATH)/contrib
+ mkdir -p $(DOCPATH)/examples