summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/coldsync/coldsync-2.2.5-r1.ebuild8
-rw-r--r--app-pda/coldsync/files/coldsync-2.2.5-broken-c++.diff21
-rw-r--r--app-pda/coldsync/files/coldsync-2.2.5-gcc3.diff10
3 files changed, 7 insertions, 32 deletions
diff --git a/app-pda/coldsync/coldsync-2.2.5-r1.ebuild b/app-pda/coldsync/coldsync-2.2.5-r1.ebuild
index 8ea9becf97dc..d65e16e7bc4b 100644
--- a/app-pda/coldsync/coldsync-2.2.5-r1.ebuild
+++ b/app-pda/coldsync/coldsync-2.2.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/coldsync/coldsync-2.2.5-r1.ebuild,v 1.12 2011/03/31 05:49:22 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/coldsync/coldsync-2.2.5-r1.ebuild,v 1.13 2011/03/31 05:50:44 ssuominen Exp $
EAPI=2
inherit eutils flag-o-matic perl-module toolchain-funcs
@@ -20,6 +20,12 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-toolchain.patch
+
+ if use perl; then
+ pushd perl/ColdSync
+ perl-module_src_prepare
+ popd
+ fi
}
src_configure() {
diff --git a/app-pda/coldsync/files/coldsync-2.2.5-broken-c++.diff b/app-pda/coldsync/files/coldsync-2.2.5-broken-c++.diff
deleted file mode 100644
index efbe4615ec16..000000000000
--- a/app-pda/coldsync/files/coldsync-2.2.5-broken-c++.diff
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/symboltable.cc
-+++ src/symboltable.cc
-@@ -12,6 +12,7 @@
- #include <map>
- #include <cstdlib> // For malloc() and friends
- #include "symboltable.h"
-+using namespace std;
-
- static char *make_c_string(const string &s);
-
---- src/symboltable.h
-+++ src/symboltable.h
-@@ -26,7 +26,7 @@
- /* Initialize the symbol table based on the
- * arguments. */
- #ifdef __cplusplus
--};
-+}
- #endif /* __cplusplus */
-
- /* This is for Emacs's benefit:
diff --git a/app-pda/coldsync/files/coldsync-2.2.5-gcc3.diff b/app-pda/coldsync/files/coldsync-2.2.5-gcc3.diff
deleted file mode 100644
index c881d7e9a64f..000000000000
--- a/app-pda/coldsync/files/coldsync-2.2.5-gcc3.diff
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/symboltable.cc
-+++ src/symboltable.cc
-@@ -7,6 +7,7 @@
- * $Id: coldsync-2.2.5-gcc3.diff,v 1.2 2011/03/31 05:22:11 ssuominen Exp $
- */
-
-+using namespace std;
- #include "config.h"
- #include <string>
- #include <map>