summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/cfg-update/ChangeLog7
-rw-r--r--app-portage/cfg-update/cfg-update-1.8.0-r6.ebuild74
-rw-r--r--app-portage/cfg-update/cfg-update-1.8.2-r2.ebuild113
-rw-r--r--app-portage/cfg-update/cfg-update-1.8.4.ebuild106
-rw-r--r--app-portage/cfg-update/cfg-update-1.8.5.ebuild106
-rw-r--r--app-portage/cfg-update/cfg-update-1.8.6.ebuild106
6 files changed, 6 insertions, 506 deletions
diff --git a/app-portage/cfg-update/ChangeLog b/app-portage/cfg-update/ChangeLog
index b6fbf8037cc4..5fe29ba54856 100644
--- a/app-portage/cfg-update/ChangeLog
+++ b/app-portage/cfg-update/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/cfg-update
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/cfg-update/ChangeLog,v 1.30 2011/11/12 20:11:38 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/cfg-update/ChangeLog,v 1.31 2011/12/05 19:30:43 rich0 Exp $
+
+ 05 Dec 2011; Richard Freeman <rich0@gentoo.org> -cfg-update-1.8.0-r6.ebuild,
+ -cfg-update-1.8.2-r2.ebuild, -cfg-update-1.8.4.ebuild,
+ -cfg-update-1.8.5.ebuild, -cfg-update-1.8.6.ebuild:
+ Clean up old versions in preparation for stabilization.
*cfg-update-1.8.7 (12 Nov 2011)
diff --git a/app-portage/cfg-update/cfg-update-1.8.0-r6.ebuild b/app-portage/cfg-update/cfg-update-1.8.0-r6.ebuild
deleted file mode 100644
index e62ef6a977e8..000000000000
--- a/app-portage/cfg-update/cfg-update-1.8.0-r6.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/cfg-update/cfg-update-1.8.0-r6.ebuild,v 1.9 2010/01/09 21:43:09 ssuominen Exp $
-
-DESCRIPTION="Easy to use GUI & CLI alternative for etc-update with safe automatic updating functionality"
-HOMEPAGE="http://people.zeelandnet.nl/xentric/"
-SRC_URI="http://people.zeelandnet.nl/xentric/${PF}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86"
-IUSE="gnome"
-
-RDEPEND="gnome? ( >=x11-misc/sux-1.0
- x11-apps/xhost
- >=dev-util/meld-0.9 )"
-
-S=${WORKDIR}/${PF}
-
-pkg_postrm() {
- ewarn
- ewarn "If you want to permanently remove cfg-update from your system"
- ewarn "you should manually remove the alias for emerge from /root/.bashrc"
- ewarn "followed by running: unalias emerge"
- ewarn "and remove the index file /var/lib/cfg-update/checksum.index"
- ewarn
- ewarn "If you are just updating to a newer version you should read the"
- ewarn "installation instructions on http://people.zeelandnet.nl/xentric"
- ewarn
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- cat >>cfg-update.conf <<-EOF
-
- INDEXFILE = /var/lib/cfg-update/checksum.index
- EOF
-}
-
-src_install() {
- exeinto /usr/bin
- doexe cfg-update emerge_with_indexing_for_cfg-update emerge_with_indexing_for_cfg-update_phphelper cfg-update_phphelper emerge_with_indexing_for_cfg-update_bashhelper
- insinto /usr/lib/cfg-update
- doins cfg-update .bashrc
- dodoc ChangeLog
- doman *.8
- insinto /etc
- doins cfg-update.conf
- keepdir /var/lib/cfg-update
-}
-
-pkg_postinst() {
- if [[ ! -e "${ROOT}"/var/lib/cfg-update/checksum.index \
- && -e "${ROOT}"/var/lib/cfg-update/checksum.index ]]
- then
- ebegin "Moving checksum.index from /usr/lib/cfg-update to /var/lib/cfg-update"
- mv "${ROOT}"/usr/lib/cfg-update/checksum.index \
- "${ROOT}"/var/lib/cfg-update/checksum.index
- eend $?
- fi
-
- if [[ ${ROOT} = / ]]
- then
- ebegin "Converting old backups to new filename format"
- cfg-update --convert-old-backups &>/dev/null
- eend $?
- ebegin "Trying to remove old emerge alias from /etc/profile"
- cfg-update --remove-old-alias &>/dev/null
- eend $?
- ewarn "Please read the installation instructions on http://people.zeelandnet.nl/xentric"
- ewarn "You need to run cfg-update --on after installation!"
- fi
-}
diff --git a/app-portage/cfg-update/cfg-update-1.8.2-r2.ebuild b/app-portage/cfg-update/cfg-update-1.8.2-r2.ebuild
deleted file mode 100644
index 6971093b13a0..000000000000
--- a/app-portage/cfg-update/cfg-update-1.8.2-r2.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/cfg-update/cfg-update-1.8.2-r2.ebuild,v 1.2 2010/07/10 22:30:03 truedfx Exp $
-
-inherit eutils
-
-DESCRIPTION="Easy to use GUI & CLI alternative for etc-update with safe automatic updating functionality"
-HOMEPAGE="http://people.zeelandnet.nl/xentric/"
-SRC_URI="http://people.zeelandnet.nl/xentric/${P}-r1.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
-IUSE="X"
-
-RDEPEND="X? ( >=x11-misc/sux-1.0
- x11-apps/xhost )"
-
-S=${WORKDIR}/${P}-r1
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-xxdiff-to-beediff.patch
- epatch "${FILESDIR}"/${P}-bashrc.patch
-}
-
-pkg_prerm() {
- if [[ ${ROOT} == / ]]
- then
- ebegin "Disabling portage hook"
- cfg-update --ebuild --disable-portage-hook
- eend $?
- ebegin "Disabling paludis hook"
- cfg-update --ebuild --disable-paludis-hook
- eend $?
- fi
-}
-
-pkg_postrm() {
- ewarn
- ewarn "If you want to permanently remove cfg-update from your system"
- ewarn "you should manually remove the alias for emerge from /root/.bashrc"
- ewarn "followed by running: unalias emerge"
- ewarn "and remove the index file /var/lib/cfg-update/checksum.index"
- ewarn
- ewarn "If you are just updating to a newer version you should read the"
- ewarn "installation instructions on http://people.zeelandnet.nl/xentric"
- ewarn
-}
-
-src_install() {
- exeinto /usr/bin
- doexe cfg-update emerge_with_indexing_for_cfg-update emerge_with_indexing_for_cfg-update_phphelper cfg-update_phphelper emerge_with_indexing_for_cfg-update_bashhelper
- insinto /usr/lib/cfg-update
- doins cfg-update cfg-update_indexing .bashrc test.tgz
- dodoc ChangeLog
- doman *.8
- insinto /etc
- doins cfg-update.conf
- doins cfg-update.hosts
- keepdir /var/lib/cfg-update
-}
-
-pkg_postinst() {
- if [[ ! -e "${ROOT}"/var/lib/cfg-update/checksum.index \
- && -e "${ROOT}"/var/lib/cfg-update/checksum.index ]]
- then
- ebegin "Moving checksum.index from /usr/lib/cfg-update to /var/lib/cfg-update"
- mv "${ROOT}"/usr/lib/cfg-update/checksum.index \
- "${ROOT}"/var/lib/cfg-update/checksum.index
- eend $?
- fi
-
- if [[ -e "${ROOT}"/usr/bin/paludis ]]
- then
- ewarn
- ewarn "If you have used Paludis version <0.20.0 on your system, chances are"
- ewarn "that you have some corrupted CONTENTS files on your system..."
- ewarn
- ewarn "Please run: cfg-update --check-packages"
- ewarn
- ewarn "The above command will check all packages installed with Paludis and"
- ewarn "will output a list of packages that need to be re-installed with"
- ewarn "Paludis 0.20.0 or higher. If you do not re-install these packages"
- ewarn "you risk losing your custom settings when updating configuration"
- ewarn "files, that belong to these packages, with cfg-update!"
- ewarn
- fi
-
- if [[ ${ROOT} == / ]]
- then
- ebegin "Moving backups to /var/lib/cfg-update/backups"
- /usr/bin/cfg-update --ebuild --move-backups
- eend $?
- fi
-
- einfo
- einfo "If this is a first time install, please check the configuration"
- einfo "in /etc/cfg-update.conf before using cfg-update:"
- einfo
- einfo "If your system does not have an X-server installed you need to"
- einfo "change the MERGE_TOOL to sdiff, imediff2 or vimdiff."
- einfo "If you have X installed, set MERGE_TOOL to your favorite GUI tool:"
- einfo "beediff (default), kdiff3, meld, gtkdiff, gvimdiff, tkdiff"
- einfo
- einfo "TIP: to maximize the chances of future automatic updates, run:"
- einfo "cfg-update --optimize-backups"
- einfo
- einfo "For an example of an updating session with screenshots visit:"
- einfo "http://people.zeelandnet.nl/xentric"
- einfo
-}
diff --git a/app-portage/cfg-update/cfg-update-1.8.4.ebuild b/app-portage/cfg-update/cfg-update-1.8.4.ebuild
deleted file mode 100644
index 5db7392bf08b..000000000000
--- a/app-portage/cfg-update/cfg-update-1.8.4.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/cfg-update/cfg-update-1.8.4.ebuild,v 1.1 2011/10/02 11:17:06 rich0 Exp $
-
-EAPI=2
-inherit eutils
-
-DESCRIPTION="Easy to use GUI & CLI alternative for etc-update with safe automatic updating functionality"
-HOMEPAGE="https://github.com/rich0/cfg-update"
-SRC_URI="https://github.com/rich0/cfg-update/tarball/${PV} -> ${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
-IUSE="X"
-
-RDEPEND="X? ( >=x11-misc/sux-1.0
- x11-apps/xhost )"
-
-S="${WORKDIR}/rich0-cfg-update-dced21c"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-}
-
-pkg_prerm() {
- if [[ ${ROOT} == / ]]
- then
- ebegin "Disabling portage hook"
- cfg-update --ebuild --disable-portage-hook
- eend $?
- ebegin "Disabling paludis hook"
- cfg-update --ebuild --disable-paludis-hook
- eend $?
- fi
-}
-
-pkg_postrm() {
- ewarn
- ewarn "If you want to permanently remove cfg-update from your system"
- ewarn "you should manually remove the alias for emerge from /root/.bashrc"
- ewarn "followed by running: unalias emerge"
- ewarn "and remove the index file /var/lib/cfg-update/checksum.index"
- ewarn
-}
-
-src_install() {
- exeinto /usr/bin
- doexe cfg-update emerge_with_indexing_for_cfg-update emerge_with_indexing_for_cfg-update_phphelper cfg-update_phphelper emerge_with_indexing_for_cfg-update_bashhelper
- insinto /usr/lib/cfg-update
- doins cfg-update cfg-update_indexing .bashrc test.tgz
- dodoc ChangeLog
- doman *.8
- insinto /etc
- doins cfg-update.conf
- doins cfg-update.hosts
- keepdir /var/lib/cfg-update
-}
-
-pkg_postinst() {
- if [[ ! -e "${ROOT}"/var/lib/cfg-update/checksum.index \
- && -e "${ROOT}"/var/lib/cfg-update/checksum.index ]]
- then
- ebegin "Moving checksum.index from /usr/lib/cfg-update to /var/lib/cfg-update"
- mv "${ROOT}"/usr/lib/cfg-update/checksum.index \
- "${ROOT}"/var/lib/cfg-update/checksum.index
- eend $?
- fi
-
- if [[ -e "${ROOT}"/usr/bin/paludis ]]
- then
- ewarn
- ewarn "If you have used Paludis version <0.20.0 on your system, chances are"
- ewarn "that you have some corrupted CONTENTS files on your system..."
- ewarn
- ewarn "Please run: cfg-update --check-packages"
- ewarn
- ewarn "The above command will check all packages installed with Paludis and"
- ewarn "will output a list of packages that need to be re-installed with"
- ewarn "Paludis 0.20.0 or higher. If you do not re-install these packages"
- ewarn "you risk losing your custom settings when updating configuration"
- ewarn "files, that belong to these packages, with cfg-update!"
- ewarn
- fi
-
- if [[ ${ROOT} == / ]]
- then
- ebegin "Moving backups to /var/lib/cfg-update/backups"
- /usr/bin/cfg-update --ebuild --move-backups
- eend $?
- fi
-
- einfo
- einfo "If this is a first time install, please check the configuration"
- einfo "in /etc/cfg-update.conf before using cfg-update:"
- einfo
- einfo "If your system does not have an X-server installed you need to"
- einfo "change the MERGE_TOOL to sdiff, imediff2 or vimdiff."
- einfo "If you have X installed, set MERGE_TOOL to your favorite GUI tool:"
- einfo "xxdiff, beediff, kdiff3, meld (default), gtkdiff, gvimdiff, tkdiff"
- einfo
- einfo "TIP: to maximize the chances of future automatic updates, run:"
- einfo "cfg-update --optimize-backups"
- einfo
-}
diff --git a/app-portage/cfg-update/cfg-update-1.8.5.ebuild b/app-portage/cfg-update/cfg-update-1.8.5.ebuild
deleted file mode 100644
index 432784253122..000000000000
--- a/app-portage/cfg-update/cfg-update-1.8.5.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/cfg-update/cfg-update-1.8.5.ebuild,v 1.1 2011/10/15 13:29:08 rich0 Exp $
-
-EAPI=2
-inherit eutils
-
-DESCRIPTION="Easy to use GUI & CLI alternative for etc-update with safe automatic updating functionality"
-HOMEPAGE="https://github.com/rich0/cfg-update"
-SRC_URI="https://github.com/rich0/cfg-update/tarball/${PV} -> ${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
-IUSE="X"
-
-RDEPEND="X? ( >=x11-misc/sux-1.0
- x11-apps/xhost )"
-
-S="${WORKDIR}/rich0-cfg-update-1866ec0"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-}
-
-pkg_prerm() {
- if [[ ${ROOT} == / ]]
- then
- ebegin "Disabling portage hook"
- cfg-update --ebuild --disable-portage-hook
- eend $?
- ebegin "Disabling paludis hook"
- cfg-update --ebuild --disable-paludis-hook
- eend $?
- fi
-}
-
-pkg_postrm() {
- ewarn
- ewarn "If you want to permanently remove cfg-update from your system"
- ewarn "you should manually remove the alias for emerge from /root/.bashrc"
- ewarn "followed by running: unalias emerge"
- ewarn "and remove the index file /var/lib/cfg-update/checksum.index"
- ewarn
-}
-
-src_install() {
- exeinto /usr/bin
- doexe cfg-update emerge_with_indexing_for_cfg-update emerge_with_indexing_for_cfg-update_phphelper cfg-update_phphelper emerge_with_indexing_for_cfg-update_bashhelper
- insinto /usr/lib/cfg-update
- doins cfg-update cfg-update_indexing .bashrc test.tgz
- dodoc ChangeLog
- doman *.8
- insinto /etc
- doins cfg-update.conf
- doins cfg-update.hosts
- keepdir /var/lib/cfg-update
-}
-
-pkg_postinst() {
- if [[ ! -e "${ROOT}"/var/lib/cfg-update/checksum.index \
- && -e "${ROOT}"/var/lib/cfg-update/checksum.index ]]
- then
- ebegin "Moving checksum.index from /usr/lib/cfg-update to /var/lib/cfg-update"
- mv "${ROOT}"/usr/lib/cfg-update/checksum.index \
- "${ROOT}"/var/lib/cfg-update/checksum.index
- eend $?
- fi
-
- if [[ -e "${ROOT}"/usr/bin/paludis ]]
- then
- ewarn
- ewarn "If you have used Paludis version <0.20.0 on your system, chances are"
- ewarn "that you have some corrupted CONTENTS files on your system..."
- ewarn
- ewarn "Please run: cfg-update --check-packages"
- ewarn
- ewarn "The above command will check all packages installed with Paludis and"
- ewarn "will output a list of packages that need to be re-installed with"
- ewarn "Paludis 0.20.0 or higher. If you do not re-install these packages"
- ewarn "you risk losing your custom settings when updating configuration"
- ewarn "files, that belong to these packages, with cfg-update!"
- ewarn
- fi
-
- if [[ ${ROOT} == / ]]
- then
- ebegin "Moving backups to /var/lib/cfg-update/backups"
- /usr/bin/cfg-update --ebuild --move-backups
- eend $?
- fi
-
- einfo
- einfo "If this is a first time install, please check the configuration"
- einfo "in /etc/cfg-update.conf before using cfg-update:"
- einfo
- einfo "If your system does not have an X-server installed you need to"
- einfo "change the MERGE_TOOL to sdiff, imediff2 or vimdiff."
- einfo "If you have X installed, set MERGE_TOOL to your favorite GUI tool:"
- einfo "xxdiff, beediff, kdiff3, meld (default), gtkdiff, gvimdiff, tkdiff"
- einfo
- einfo "TIP: to maximize the chances of future automatic updates, run:"
- einfo "cfg-update --optimize-backups"
- einfo
-}
diff --git a/app-portage/cfg-update/cfg-update-1.8.6.ebuild b/app-portage/cfg-update/cfg-update-1.8.6.ebuild
deleted file mode 100644
index 1ef0086318c9..000000000000
--- a/app-portage/cfg-update/cfg-update-1.8.6.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/cfg-update/cfg-update-1.8.6.ebuild,v 1.1 2011/10/29 12:24:01 rich0 Exp $
-
-EAPI=2
-inherit eutils
-
-DESCRIPTION="Easy to use GUI & CLI alternative for etc-update with safe automatic updating functionality"
-HOMEPAGE="https://github.com/rich0/cfg-update"
-SRC_URI="https://github.com/rich0/cfg-update/tarball/${PV} -> ${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
-IUSE="X"
-
-RDEPEND="X? ( >=x11-misc/sux-1.0
- x11-apps/xhost )"
-
-S="${WORKDIR}/rich0-cfg-update-0239160"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-}
-
-pkg_prerm() {
- if [[ ${ROOT} == / ]]
- then
- ebegin "Disabling portage hook"
- cfg-update --ebuild --disable-portage-hook
- eend $?
- ebegin "Disabling paludis hook"
- cfg-update --ebuild --disable-paludis-hook
- eend $?
- fi
-}
-
-pkg_postrm() {
- ewarn
- ewarn "If you want to permanently remove cfg-update from your system"
- ewarn "you should manually remove the alias for emerge from /root/.bashrc"
- ewarn "followed by running: unalias emerge"
- ewarn "and remove the index file /var/lib/cfg-update/checksum.index"
- ewarn
-}
-
-src_install() {
- exeinto /usr/bin
- doexe cfg-update emerge_with_indexing_for_cfg-update emerge_with_indexing_for_cfg-update_phphelper cfg-update_phphelper emerge_with_indexing_for_cfg-update_bashhelper
- insinto /usr/lib/cfg-update
- doins cfg-update cfg-update_indexing .bashrc test.tgz
- dodoc ChangeLog
- doman *.8
- insinto /etc
- doins cfg-update.conf
- doins cfg-update.hosts
- keepdir /var/lib/cfg-update
-}
-
-pkg_postinst() {
- if [[ ! -e "${ROOT}"/var/lib/cfg-update/checksum.index \
- && -e "${ROOT}"/var/lib/cfg-update/checksum.index ]]
- then
- ebegin "Moving checksum.index from /usr/lib/cfg-update to /var/lib/cfg-update"
- mv "${ROOT}"/usr/lib/cfg-update/checksum.index \
- "${ROOT}"/var/lib/cfg-update/checksum.index
- eend $?
- fi
-
- if [[ -e "${ROOT}"/usr/bin/paludis ]]
- then
- ewarn
- ewarn "If you have used Paludis version <0.20.0 on your system, chances are"
- ewarn "that you have some corrupted CONTENTS files on your system..."
- ewarn
- ewarn "Please run: cfg-update --check-packages"
- ewarn
- ewarn "The above command will check all packages installed with Paludis and"
- ewarn "will output a list of packages that need to be re-installed with"
- ewarn "Paludis 0.20.0 or higher. If you do not re-install these packages"
- ewarn "you risk losing your custom settings when updating configuration"
- ewarn "files, that belong to these packages, with cfg-update!"
- ewarn
- fi
-
- if [[ ${ROOT} == / ]]
- then
- ebegin "Moving backups to /var/lib/cfg-update/backups"
- /usr/bin/cfg-update --ebuild --move-backups
- eend $?
- fi
-
- einfo
- einfo "If this is a first time install, please check the configuration"
- einfo "in /etc/cfg-update.conf before using cfg-update:"
- einfo
- einfo "If your system does not have an X-server installed you need to"
- einfo "change the MERGE_TOOL to sdiff, imediff2 or vimdiff."
- einfo "If you have X installed, set MERGE_TOOL to your favorite GUI tool:"
- einfo "xxdiff, beediff, kdiff3, meld (default), gtkdiff, gvimdiff, tkdiff"
- einfo
- einfo "TIP: to maximize the chances of future automatic updates, run:"
- einfo "cfg-update --optimize-backups"
- einfo
-}