summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-sci/electric/electric-6.07-r1.ebuild')
-rw-r--r--app-sci/electric/electric-6.07-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-sci/electric/electric-6.07-r1.ebuild b/app-sci/electric/electric-6.07-r1.ebuild
new file mode 100644
index 000000000000..974b46f7c2a4
--- /dev/null
+++ b/app-sci/electric/electric-6.07-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/electric/electric-6.07-r1.ebuild,v 1.1 2004/04/05 14:04:34 phosphan Exp $
+
+IUSE="motif"
+
+DESCRIPTION="Electric is a sophisticated electrical CAD system that can handle many forms of circuit design"
+HOMEPAGE="http://www.gnu.org/software/electric/electric.html"
+SRC_URI="http://ftp.gnu.org/pub/gnu/electric/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="virtual/glibc
+ motif? ( x11-libs/openmotif )"
+
+RDEPEND=""
+
+src_compile() {
+ econf || die "./configure failed"
+ sed -e 's:/usr/local/:/usr/:g' -i src/include/config.h
+ emake || die
+}
+
+src_install() {
+ einstall
+
+ dodoc ChangeLog COPYING README
+}