summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-sci/scilab')
-rw-r--r--app-sci/scilab/ChangeLog9
-rw-r--r--app-sci/scilab/Manifest2
-rw-r--r--app-sci/scilab/files/digest-scilab-2.7-r32
-rw-r--r--app-sci/scilab/scilab-2.7-r3.ebuild142
4 files changed, 153 insertions, 2 deletions
diff --git a/app-sci/scilab/ChangeLog b/app-sci/scilab/ChangeLog
index e20782f7d26d..b1911ac3be23 100644
--- a/app-sci/scilab/ChangeLog
+++ b/app-sci/scilab/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/scilab
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/scilab/ChangeLog,v 1.10 2003/10/12 17:53:36 george Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/scilab/ChangeLog,v 1.11 2004/03/22 13:25:16 phosphan Exp $
+
+*scilab-2.7-r3 (22 Mar 2004)
+
+ 22 Mar 2004; Patrick Kursawe <phosphan@gentoo.org> scilab-2.7-r3.ebuild:
+ Trying to fix bug #40225 by providing an X server during build.
11 Oct 2003; George Shapovalov <geore@gentoo.org> scilab-2.7-r2.ebuild :
added few more dependensies for gtk interface
diff --git a/app-sci/scilab/Manifest b/app-sci/scilab/Manifest
index 74b824933058..d78cac1d4c53 100644
--- a/app-sci/scilab/Manifest
+++ b/app-sci/scilab/Manifest
@@ -1,3 +1,4 @@
+MD5 eeef730bed72fd65264a9120baf45912 scilab-2.7-r3.ebuild 3648
MD5 dad730249717cbeff055be53d6473d07 scilab-2.6.ebuild 2840
MD5 e62919913a91a833078640794c92a3fd scilab-2.7-r2.ebuild 3628
MD5 a7c67baf97c161adf3b92188be1dddf9 ChangeLog 2165
@@ -8,3 +9,4 @@ MD5 1d6cf95b60df9aed59392d68189bb25d files/digest-scilab-2.6 67
MD5 08e3affe50b12d19408b7e389b08a964 files/digest-scilab-2.7 67
MD5 f8e77491ef5140fe63fbe21ca1964377 files/digest-scilab-2.7-r1 135
MD5 f8e77491ef5140fe63fbe21ca1964377 files/digest-scilab-2.7-r2 135
+MD5 f8e77491ef5140fe63fbe21ca1964377 files/digest-scilab-2.7-r3 135
diff --git a/app-sci/scilab/files/digest-scilab-2.7-r3 b/app-sci/scilab/files/digest-scilab-2.7-r3
new file mode 100644
index 000000000000..c742d1e38c77
--- /dev/null
+++ b/app-sci/scilab/files/digest-scilab-2.7-r3
@@ -0,0 +1,2 @@
+MD5 e8aa1ede5efa20eeced284963d08bebb scilab-2.7.src.tar.gz 9510676
+MD5 712df122ba9d3dabf17e6016f33efcc4 patch_browsehelp.tar.gz 622246
diff --git a/app-sci/scilab/scilab-2.7-r3.ebuild b/app-sci/scilab/scilab-2.7-r3.ebuild
new file mode 100644
index 000000000000..2d38bf123bde
--- /dev/null
+++ b/app-sci/scilab/scilab-2.7-r3.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/scilab/scilab-2.7-r3.ebuild,v 1.1 2004/03/22 13:25:16 phosphan Exp $
+
+inherit virtualx
+
+DESCRIPTION="Scientific software package for numerical computations, Matlab lookalike"
+SRC_URI="ftp://ftp.inria.fr/INRIA/Projects/Meta2/Scilab/distributions/${P}.src.tar.gz
+ http://www-rocq.inria.fr/scilab/bugfix/patch_browsehelp.tar.gz"
+HOMEPAGE="http://www.scilab.org/"
+
+LICENSE="scilab"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="tcltk gtk"
+
+DEPEND="virtual/x11
+ x11-libs/Xaw3d
+ sys-libs/ncurses
+ tcltk? ( dev-lang/tk )
+ gtk? ( =x11-libs/gtk+-1.2*
+ >=gnome-base/gnome-libs-1.4.2
+ >=dev-libs/glib-2.2
+ media-libs/jpeg
+ media-libs/libpng
+ sys-libs/zlib )"
+
+pkg_setup() {
+ local SCLB
+ SCLB=`which scilab`
+ if [ -e "${SCLB}" ]; then
+ ewarn "Previous version of scilab was detected on your system"
+ ewarn "Unfortunately these versions cause problems for newer ones during update"
+ ewarn 'Please uninstall it with "emerge unmerge scilab" before continuig'
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} && unpack ${DISTFILES}/patch_browsehelp.tar.gz
+}
+
+src_compile() {
+ local myopts
+
+ use tcltk || myopts="${myopts} --without-tk"
+ use gtk && myopts="${myopts} --with-gtk" || myopts="${myopts} --without-gtk"
+
+ econf ${myopts} || die "./configure failed"
+ export HOME=${S}
+ Xmake all || die
+}
+
+src_install() {
+ PVMBINDISTFILES="\
+ ${P}/pvm3/Readme \
+ ${P}/pvm3/lib/pvm \
+ ${P}/pvm3/lib/pvmd \
+ ${P}/pvm3/lib/pvmtmparch \
+ ${P}/pvm3/lib/pvmgetarch \
+ ${P}/pvm3/lib/LINUX/pvmd3 \
+ ${P}/pvm3/lib/LINUX/pvmgs \
+ ${P}/pvm3/lib/LINUX/pvm \
+ ${P}/pvm3/bin/LINUX/*"
+
+ BINDISTFILES="\
+ ${P}/.binary \
+ ${P}/.pvmd.conf \
+ ${P}/ACKNOWLEDGEMENTS \
+ ${P}/CHANGES \
+ ${P}/Makefile \
+ ${P}/Makefile.OBJ \
+ ${P}/Makefile.incl \
+ ${P}/Makemex \
+ ${P}/Path.incl \
+ ${P}/README_Unix \
+ ${P}/Version.incl \
+ ${P}/configure \
+ ${P}/libtool \
+ ${P}/license.txt \
+ ${P}/licence.txt \
+ ${P}/scilab.quit \
+ ${P}/scilab.star \
+ ${P}/X11_defaults \
+ ${P}/bin \
+ ${P}/config \
+ ${P}/contrib \
+ ${P}/demos \
+ ${P}/examples \
+ ${P}/imp/NperiPos.ps \
+ ${P}/imp/giffonts \
+ ${P}/macros \
+ ${P}/man/eng/*.htm \
+ ${P}/man/eng/*/*.htm \
+ ${P}/man/fr/*/*.htm \
+ ${P}/man/fr/*.htm \
+ ${P}/man/*.dtd \
+ ${P}/man/*/*.xsl \
+ ${P}/maple \
+ ${P}/routines/*.h \
+ ${P}/routines/Make.lib \
+ ${P}/routines/default/FCreate \
+ ${P}/routines/default/Flist \
+ ${P}/routines/default/README \
+ ${P}/routines/default/fundef \
+ ${P}/routines/default/*.c \
+ ${P}/routines/default/*.f \
+ ${P}/routines/default/*.h \
+ ${P}/routines/graphics/Math.h \
+ ${P}/routines/graphics/Graphics.h \
+ ${P}/routines/graphics/Entities.h \
+ ${P}/routines/interf/*.h \
+ ${P}/routines/intersci/sparse.h \
+ ${P}/routines/menusX/*.h \
+ ${P}/routines/scicos/scicos.h \
+ ${P}/routines/sun/*.h \
+ ${P}/routines/xsci/*.h \
+ ${P}/scripts \
+ ${P}/tcl \
+ ${P}/tests \
+ ${P}/util"
+
+ touch .binary
+ strip bin/scilex
+ cd ${S}/tests && make distclean
+ cd ${S}/examples && make distclean
+ dodir /usr/lib
+ (cd ${S}/..; tar cf - ${BINDISTFILES} ${PVMBINDISTFILES} | (cd ${D}/usr/lib; tar xf -))
+ rm .binary
+
+ dodir /usr/bin
+ dosym /usr/lib/${P}/bin/scilab /usr/bin/scilab
+ dosym /usr/lib/${P}/bin/intersci /usr/bin/intersci
+ dosym /usr/lib/${P}/bin/intersci-n /usr/bin/intersci-n
+
+ #now scilab wants to create some wrappers, and we will need to adjust the paths
+ cd ${D}/usr/lib/${P}
+ make || die "wrapper creation failed"
+ cd macros && make && cd .. || die macros creation failed
+ grep -rle "${D}" * | xargs sed -i -e "s:${D}:/:g"
+}