summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/mksh/mksh-40d.ebuild')
-rw-r--r--app-shells/mksh/mksh-40d.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-shells/mksh/mksh-40d.ebuild b/app-shells/mksh/mksh-40d.ebuild
new file mode 100644
index 000000000000..246c0720d555
--- /dev/null
+++ b/app-shells/mksh/mksh-40d.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/mksh/mksh-40d.ebuild,v 1.1 2011/12/12 03:23:17 patrick Exp $
+
+inherit eutils
+
+DESCRIPTION="MirBSD KSH Shell"
+HOMEPAGE="http://mirbsd.de/mksh"
+ARC4_VERSION="1.14"
+SRC_URI="http://www.mirbsd.org/MirOS/dist/mir/mksh/${PN}-R${PV}.cpio.gz
+ http://www.mirbsd.org/MirOS/dist/hosted/other/arc4random.c.${ARC4_VERSION}"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND="app-arch/cpio"
+RDEPEND=""
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ gzip -dc "${DISTDIR}/${PN}-R${PV}.cpio.gz" | cpio -mid
+ cp "${DISTDIR}/arc4random.c.${ARC4_VERSION}" "${S}/arc4random.c" || die
+}
+
+src_compile() {
+ tc-export CC
+ # we can't assume lto existing/enabled, so we add a fallback
+ sh Build.sh -r -c lto || sh Rebuild.sh || die
+}
+
+src_install() {
+ exeinto /bin
+ doexe mksh || die
+ doman mksh.1 || die
+ dodoc dot.mkshrc || die
+}
+
+src_test() {
+ ./test.sh || die
+}