summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/ksh/ChangeLog6
-rw-r--r--app-shells/ksh/ksh-93.20071105.ebuild7
-rw-r--r--app-shells/ksh/ksh-93.20081104.ebuild7
-rw-r--r--app-shells/ksh/ksh-93.20090505.ebuild5
4 files changed, 16 insertions, 9 deletions
diff --git a/app-shells/ksh/ChangeLog b/app-shells/ksh/ChangeLog
index 9d0d57812793..ab2aee405c78 100644
--- a/app-shells/ksh/ChangeLog
+++ b/app-shells/ksh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/ksh
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.40 2010/01/22 01:22:10 cla Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.41 2010/01/24 19:11:19 vapier Exp $
+
+ 24 Jan 2010; Mike Frysinger <vapier@gentoo.org> ksh-93.20071105.ebuild,
+ ksh-93.20081104.ebuild, ksh-93.20090505.ebuild:
+ Run helper script through /bin/sh #294817.
*ksh-93.20090505 (22 Jan 2010)
diff --git a/app-shells/ksh/ksh-93.20071105.ebuild b/app-shells/ksh/ksh-93.20071105.ebuild
index 5ced0cea8933..c3b844e5640e 100644
--- a/app-shells/ksh/ksh-93.20071105.ebuild
+++ b/app-shells/ksh/ksh-93.20071105.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20071105.ebuild,v 1.6 2009/09/06 19:05:41 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20071105.ebuild,v 1.7 2010/01/24 19:11:19 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -39,7 +39,8 @@ src_unpack() {
unpack INIT.${INIT_RELEASE}.tgz
# `package read` will unpack any tarballs put in place.
- "${S}"/bin/package read || die
+ # run through /bin/sh due to #141906
+ /bin/sh "${S}"/bin/package read || die
}
src_compile() {
diff --git a/app-shells/ksh/ksh-93.20081104.ebuild b/app-shells/ksh/ksh-93.20081104.ebuild
index 91c5bae17223..8b1cce2d8439 100644
--- a/app-shells/ksh/ksh-93.20081104.ebuild
+++ b/app-shells/ksh/ksh-93.20081104.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20081104.ebuild,v 1.2 2009/09/06 19:05:41 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20081104.ebuild,v 1.3 2010/01/24 19:11:19 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -39,7 +39,8 @@ src_unpack() {
unpack INIT.${INIT_RELEASE}.tgz
# `package read` will unpack any tarballs put in place.
- "${S}"/bin/package read || die
+ # run through /bin/sh due to #141906
+ /bin/sh "${S}"/bin/package read || die
}
src_compile() {
diff --git a/app-shells/ksh/ksh-93.20090505.ebuild b/app-shells/ksh/ksh-93.20090505.ebuild
index 7d1bc2b82d3f..14ebd0ee0ac3 100644
--- a/app-shells/ksh/ksh-93.20090505.ebuild
+++ b/app-shells/ksh/ksh-93.20090505.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20090505.ebuild,v 1.1 2010/01/22 01:22:10 cla Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20090505.ebuild,v 1.2 2010/01/24 19:11:19 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -39,7 +39,8 @@ src_unpack() {
unpack INIT.${INIT_RELEASE}.tgz
# `package read` will unpack any tarballs put in place.
- "${S}"/bin/package read || die
+ # run through /bin/sh due to #141906
+ /bin/sh "${S}"/bin/package read || die
}
src_compile() {