summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/aspell')
-rw-r--r--app-text/aspell/ChangeLog8
-rw-r--r--app-text/aspell/aspell-0.60.6.ebuild105
2 files changed, 112 insertions, 1 deletions
diff --git a/app-text/aspell/ChangeLog b/app-text/aspell/ChangeLog
index af857f053824..c6ae8ed643c4 100644
--- a/app-text/aspell/ChangeLog
+++ b/app-text/aspell/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/aspell
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.100 2008/01/26 18:49:16 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.101 2008/04/27 17:52:51 philantrop Exp $
+
+*aspell-0.60.6 (27 Apr 2008)
+
+ 27 Apr 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +aspell-0.60.6.ebuild:
+ Version bump as per bug 218756.
26 Jan 2008; Wulf C. Krueger <philantrop@gentoo.org>
+files/aspell-0.60.5-gcc-4.3.patch, aspell-0.60.5.ebuild:
diff --git a/app-text/aspell/aspell-0.60.6.ebuild b/app-text/aspell/aspell-0.60.6.ebuild
new file mode 100644
index 000000000000..83ef839b8216
--- /dev/null
+++ b/app-text/aspell/aspell-0.60.6.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.60.6.ebuild,v 1.1 2008/04/27 17:52:51 philantrop Exp $
+
+# N.B. This is before inherit of autotools, as autotools.eclass adds the
+# relevant dependencies to DEPEND.
+WANT_AUTOMAKE="1.10"
+
+inherit libtool eutils flag-o-matic autotools
+
+DESCRIPTION="A spell checker replacement for ispell"
+HOMEPAGE="http://aspell.net/"
+SRC_URI="mirror://gnu/aspell/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="gpm nls examples"
+# Note; app-text/aspell-0.6 and app-dicts/aspell-en-0.6 must go stable together
+
+# Build PDEPEND from list of language codes provided in the tree.
+# The PDEPEND string is static - this code just makes it easier to maintain.
+def="app-dicts/aspell-en"
+for l in \
+ "af" "be" "bg" "br" "ca" "cs" "cy" "da" "de" "el" \
+ "en" "eo" "es" "et" "fi" "fo" "fr" "ga" "gl" "he" \
+ "hr" "is" "it" "nl" "no" "pl" "pt" "ro" "ru" "sk" \
+ "sl" "sr" "sv" "uk" "vi"; do
+ dep="linguas_${l}? ( app-dicts/aspell-${l} )"
+ [[ -z ${PDEPEND} ]] &&
+ PDEPEND="${dep}" ||
+ PDEPEND="${PDEPEND}
+${dep}"
+ def="!linguas_${l}? ( ${def} )"
+done
+PDEPEND="${PDEPEND}
+${def}"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( sys-libs/gpm )
+ nls? ( virtual/libintl )
+ !=app-dicts/aspell-en-0.5*"
+# English dictionary 0.5 is incompatible with aspell-0.6
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/aspell-0.60.3-templateinstantiations.patch
+ epatch "${FILESDIR}/${PN}-0.60.5-nls.patch"
+
+ eautomake
+ elibtoolize --reverse-deps
+}
+
+src_compile() {
+ use gpm && append-ldflags -lgpm
+ filter-flags -fno-rtti
+ filter-flags -fvisibility=hidden #77109
+ filter-flags -maltivec -mabi=altivec
+ use ppc && append-flags -mno-altivec
+
+ econf \
+ $(use_enable nls) \
+ --disable-static \
+ --sysconfdir=/etc/aspell \
+ --enable-docdir=/usr/share/doc/${PF} || die "econf failed"
+
+ emake || die "compilation failed"
+}
+
+src_install() {
+ dodoc README* TODO || die "installing docs failed"
+
+ emake DESTDIR="${D}" install || die "installation failed"
+ mv "${D}"/usr/share/doc/${PF}/man-html "${D}"/usr/share/doc/${PF}/html
+ mv "${D}"/usr/share/doc/${PF}/man-text "${D}"/usr/share/doc/${PF}/text
+
+ # install ispell/aspell compatibility scripts
+ exeinto /usr/bin
+ newexe scripts/ispell ispell-aspell
+ newexe scripts/spell spell-aspell
+
+ if use examples ; then
+ cd examples
+ make clean || die
+ docinto examples
+ dodoc "${S}"/examples/* || die "installing examples failed"
+ fi
+}
+
+pkg_postinst() {
+ elog "You will need to install a dictionary now. Please choose an"
+ elog "aspell-<LANG> dictionary from the app-dicts category"
+ elog "After installing an aspell dictionary for your language(s),"
+ elog "You may use the aspell-import utility to import your personal"
+ elog "dictionaries from ispell, pspell and the older aspell"
+
+ ewarn ""
+ ewarn "Please re-install ALL your aspell-LANG dictionaries"
+ ewarn ""
+ ebeep 5
+}