summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/convmv')
-rw-r--r--app-text/convmv/ChangeLog10
-rw-r--r--app-text/convmv/convmv-1.10.ebuild11
-rw-r--r--app-text/convmv/convmv-1.12.ebuild36
3 files changed, 49 insertions, 8 deletions
diff --git a/app-text/convmv/ChangeLog b/app-text/convmv/ChangeLog
index f4b1bea53d70..f35c84326545 100644
--- a/app-text/convmv/ChangeLog
+++ b/app-text/convmv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/convmv
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/convmv/ChangeLog,v 1.33 2007/06/10 21:57:06 kumba Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/convmv/ChangeLog,v 1.34 2008/06/07 01:53:16 robbat2 Exp $
+
+*convmv-1.12 (07 Jun 2008)
+
+ 07 Jun 2008; Robin H. Johnson <robbat2@gentoo.org> convmv-1.10.ebuild,
+ +convmv-1.12.ebuild:
+ Version bump per bug #214424, and also clean up syntax.
10 Jun 2007; Joshua Kinard <kumba@gentoo.org> convmv-1.10.ebuild:
Stable on mips, per #181572.
diff --git a/app-text/convmv/convmv-1.10.ebuild b/app-text/convmv/convmv-1.10.ebuild
index 413f1e305c2a..249d4e914d9d 100644
--- a/app-text/convmv/convmv-1.10.ebuild
+++ b/app-text/convmv/convmv-1.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/convmv/convmv-1.10.ebuild,v 1.13 2007/06/10 21:57:06 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/convmv/convmv-1.10.ebuild,v 1.14 2008/06/07 01:53:16 robbat2 Exp $
inherit eutils
@@ -20,15 +20,14 @@ src_compile() {
}
src_install() {
- einstall DESTDIR=${D} PREFIX=/usr || die "einstall failed"
+ einstall DESTDIR="${D}" PREFIX=/usr || die "einstall failed"
dodoc CREDITS Changes TODO VERSION
}
src_test() {
- cd ${S}
unpack ./testsuite.tar
# Never make assumptions as to the ordering of files inside a directory!
- epatch ${FILESDIR}/${PN}-1.10-testcase-cleanup.patch
- cd ${S}/suite
+ epatch "${FILESDIR}"/${PN}-1.10-testcase-cleanup.patch
+ cd "${S}"/suite
./dotests.sh || die "Tests failed"
}
diff --git a/app-text/convmv/convmv-1.12.ebuild b/app-text/convmv/convmv-1.12.ebuild
new file mode 100644
index 000000000000..287b7325cca7
--- /dev/null
+++ b/app-text/convmv/convmv-1.12.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/convmv/convmv-1.12.ebuild,v 1.1 2008/06/07 01:53:16 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="convert filenames to utf8 or any other charset"
+HOMEPAGE="http://j3e.de/linux/convmv"
+SRC_URI="http://j3e.de/linux/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall DESTDIR="${D}" PREFIX=/usr || die "einstall failed"
+ dodoc CREDITS Changes TODO VERSION
+}
+
+src_test() {
+ unpack ./testsuite.tar
+
+ # Patch merged by upstream
+ # Never make assumptions as to the ordering of files inside a directory!
+ #EPATCH_OPTS="-d ${S}/suite/" epatch "${FILESDIR}"/${PN}-1.10-testcase-cleanup.patch
+
+ cd "${S}"/suite
+ ./dotests.sh || die "Tests failed"
+}