summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xdvipdfmx/xdvipdfmx-0.7.8_p20120701.ebuild')
-rw-r--r--app-text/xdvipdfmx/xdvipdfmx-0.7.8_p20120701.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-text/xdvipdfmx/xdvipdfmx-0.7.8_p20120701.ebuild b/app-text/xdvipdfmx/xdvipdfmx-0.7.8_p20120701.ebuild
new file mode 100644
index 000000000000..f26f04051bb5
--- /dev/null
+++ b/app-text/xdvipdfmx/xdvipdfmx-0.7.8_p20120701.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xdvipdfmx/xdvipdfmx-0.7.8_p20120701.ebuild,v 1.1 2012/07/26 12:14:15 aballier Exp $
+
+EAPI="4"
+
+DESCRIPTION="Extended dvipdfmx for use with XeTeX and other unicode TeXs."
+HOMEPAGE="http://scripts.sil.org/svn-view/xdvipdfmx/
+ http://tug.org/texlive/"
+SRC_URI="mirror://gentoo/texlive-${PV#*_p}-source.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="!<app-text/texlive-core-2010
+ dev-libs/kpathsea
+ sys-libs/zlib
+ media-libs/freetype:2
+ media-libs/fontconfig
+ >=media-libs/libpng-1.2.43-r2:0
+ app-text/libpaper"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# for dvipdfmx.cfg
+RDEPEND="${RDEPEND}
+ app-text/dvipdfmx"
+
+S=${WORKDIR}/texlive-${PV#*_p}-source/texk/${PN}
+
+src_configure() {
+ econf \
+ --with-system-kpathsea \
+ --with-system-zlib \
+ --with-system-libpng \
+ --with-system-freetype2
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README TODO BUGS AUTHORS ChangeLog ChangeLog.TL
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc
+ fi
+}