summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xmlto/xmlto-0.0.22.ebuild')
-rw-r--r--app-text/xmlto/xmlto-0.0.22.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/app-text/xmlto/xmlto-0.0.22.ebuild b/app-text/xmlto/xmlto-0.0.22.ebuild
index 854d0519fbc0..d93037e2593e 100644
--- a/app-text/xmlto/xmlto-0.0.22.ebuild
+++ b/app-text/xmlto/xmlto-0.0.22.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xmlto/xmlto-0.0.22.ebuild,v 1.5 2009/07/08 14:52:11 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmlto/xmlto-0.0.22.ebuild,v 1.6 2009/07/08 19:48:27 ssuominen Exp $
EAPI=2
inherit eutils autotools
@@ -14,13 +14,14 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE="latex"
-RDEPEND="app-shells/bash
+RDEPEND="userland_GNU? ( sys-apps/which )
+ app-shells/bash
dev-libs/libxslt
>=app-text/docbook-xsl-stylesheets-1.62.0-r1
~app-text/docbook-xml-dtd-4.2
|| ( sys-apps/util-linux
app-misc/getopt )
- || ( || ( >=sys-apps/coreutils-6.10-r1 sys-apps/mktemp )
+ || ( >=sys-apps/coreutils-6.10-r1 sys-apps/mktemp
sys-freebsd/freebsd-ubin )
latex? ( >=app-text/passivetex-1.25
>=dev-tex/xmltex-1.9-r2 )"
@@ -28,15 +29,14 @@ DEPEND="${RDEPEND}
sys-devel/flex"
src_prepare() {
- epatch "${FILESDIR}"/${P}-format_fo_passivetex_check.patch
- epatch "${FILESDIR}"/${P}-parallelmake.patch
-
+ epatch "${FILESDIR}"/${P}-format_fo_passivetex_check.patch \
+ "${FILESDIR}"/${P}-parallelmake.patch
eautoreconf
}
src_configure() {
local myconf
- has_version sys-apps/util-linux || myconf+=" --with-getopt=getopt-long"
+ has_version sys-apps/util-linux || myconf="--with-getopt=getopt-long"
econf --prefix=/usr ${myconf}
}