summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/dos2unix/ChangeLog7
-rw-r--r--app-text/dos2unix/dos2unix-5.1.1.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/app-text/dos2unix/ChangeLog b/app-text/dos2unix/ChangeLog
index 4c41212afb03..9d661122efa2 100644
--- a/app-text/dos2unix/ChangeLog
+++ b/app-text/dos2unix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/dos2unix
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.52 2010/07/06 08:47:22 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.53 2010/09/03 05:29:35 jlec Exp $
+
+*dos2unix-5.1.1 (03 Sep 2010)
+
+ 03 Sep 2010; Justin Lecher <jlec@gentoo.org> +dos2unix-5.1.1.ebuild:
+ Version Bump
06 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> dos2unix-5.1.ebuild:
ppc64 stable wrt #324553
diff --git a/app-text/dos2unix/dos2unix-5.1.1.ebuild b/app-text/dos2unix/dos2unix-5.1.1.ebuild
new file mode 100644
index 000000000000..ed5e8e052114
--- /dev/null
+++ b/app-text/dos2unix/dos2unix-5.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/dos2unix-5.1.1.ebuild,v 1.1 2010/09/03 05:29:35 jlec Exp $
+
+EAPI="3"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Convert DOS or MAC text files to UNIX format or vice versa"
+HOMEPAGE="http://www.xs4all.nl/~waterlan/dos2unix.html http://sourceforge.net/projects/dos2unix/"
+SRC_URI="
+ http://www.xs4all.nl/~waterlan/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="nls"
+
+DEPEND="virtual/libintl"
+RDEPEND="
+ ${DEPEND}
+ !app-text/hd2u
+ !app-text/unix2dos"
+
+src_prepare() {
+ sed \
+ -e '/^LDFLAGS/s|=|+=|' \
+ -e '/^CC/s|=|?=|' \
+ -e '/CFLAGS_OS \+=/d' \
+ -e '/LDFLAGS_EXTRA \+=/d' \
+ -i "${S}"/Makefile
+ tc-export CC
+}
+
+lintl() {
+ # same logic as from virtual/libintl
+ use !elibc_glibc && use !elibc_uclibc && echo "-lintl"
+}
+
+src_compile() {
+ emake prefix="${EPREFIX}"/usr \
+ $(use nls && echo "LDFLAGS_EXTRA=$(lintl)" || echo "ENABLE_NLS=") \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}"/usr \
+ $(use nls || echo "ENABLE_NLS=") install \
+ || die "emake install failed"
+}