summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/sword/ChangeLog7
-rw-r--r--app-text/sword/files/digest-sword-1.5.93
-rw-r--r--app-text/sword/sword-1.5.9.ebuild49
3 files changed, 58 insertions, 1 deletions
diff --git a/app-text/sword/ChangeLog b/app-text/sword/ChangeLog
index e4b466836288..00e4cea70c5e 100644
--- a/app-text/sword/ChangeLog
+++ b/app-text/sword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/sword
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sword/ChangeLog,v 1.29 2006/07/05 09:45:22 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sword/ChangeLog,v 1.30 2006/10/21 17:09:55 squinky86 Exp $
+
+*sword-1.5.9 (21 Oct 2006)
+
+ 21 Oct 2006; Jon Hood <squinky86@gentoo.org> +sword-1.5.9.ebuild:
+ Version bump to support bibletime-1.6.
05 Jul 2006; <nixnut@gentoo.org> sword-1.5.8-r1.ebuild:
Added ~ppc wrt bug #136709
diff --git a/app-text/sword/files/digest-sword-1.5.9 b/app-text/sword/files/digest-sword-1.5.9
new file mode 100644
index 000000000000..c90617a497e6
--- /dev/null
+++ b/app-text/sword/files/digest-sword-1.5.9
@@ -0,0 +1,3 @@
+MD5 e1f1af8c2add8310d0bbcddc9af523b8 sword-1.5.9.tar.gz 1816315
+RMD160 7fb20370801c493afcce76f2bad1651d77722973 sword-1.5.9.tar.gz 1816315
+SHA256 dd170431235cc419cbe6c40362640927a78dc93e082623709abe1310fe804481 sword-1.5.9.tar.gz 1816315
diff --git a/app-text/sword/sword-1.5.9.ebuild b/app-text/sword/sword-1.5.9.ebuild
new file mode 100644
index 000000000000..62ececfce1ea
--- /dev/null
+++ b/app-text/sword/sword-1.5.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sword/sword-1.5.9.ebuild,v 1.1 2006/10/21 17:09:55 squinky86 Exp $
+
+DESCRIPTION="Library for Bible reading software."
+HOMEPAGE="http://www.crosswire.org/sword/"
+SRC_URI="http://www.crosswire.org/ftpmirror/pub/sword/source/v1.5/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="curl debug icu lucene"
+
+RDEPEND="sys-libs/zlib
+ curl? ( net-misc/curl )
+ icu? ( dev-libs/icu )
+ lucene? ( dev-cpp/clucene )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ local myconf="--without-lucene --with-zlib --with-conf
+ $(use_enable debug) $(use_with curl)"
+
+ econf --with-zlib \
+ --with-conf \
+ $(use_enable curl) \
+ $(use_enable debug) \
+ $(use_with icu) \
+ $(use_enable lucene) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS CODINGSTYLE ChangeLog INSTALL README
+
+ cp -R samples examples ${D}/usr/share/doc/${PF}/
+}
+
+pkg_postinst() {
+ echo
+ einfo "Check out http://www.crosswire.org/sword/modules/"
+ einfo "to download modules that you would like to use with SWORD."
+ einfo "Follow module installation instructions found on"
+ einfo "the web or in /usr/share/doc/${PF}/INSTALL.gz."
+ echo
+}