summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/calibre/ChangeLog8
-rw-r--r--app-text/calibre/calibre-0.8.68.ebuild (renamed from app-text/calibre/calibre-0.8.66.ebuild)11
2 files changed, 17 insertions, 2 deletions
diff --git a/app-text/calibre/ChangeLog b/app-text/calibre/ChangeLog
index 51798dd94583..b2130e4fd25b 100644
--- a/app-text/calibre/ChangeLog
+++ b/app-text/calibre/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/calibre
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/calibre/ChangeLog,v 1.225 2012/09/04 16:45:46 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/calibre/ChangeLog,v 1.226 2012/09/07 20:17:54 zmedico Exp $
+
+*calibre-0.8.68 (07 Sep 2012)
+
+ 07 Sep 2012; Zac Medico <zmedico@gentoo.org> +calibre-0.8.68.ebuild,
+ -calibre-0.8.66.ebuild:
+ 0.8.68 version bump.
04 Sep 2012; Zac Medico <zmedico@gentoo.org> calibre-0.8.67.ebuild:
Use system liberation-fonts for bug #433932.
diff --git a/app-text/calibre/calibre-0.8.66.ebuild b/app-text/calibre/calibre-0.8.68.ebuild
index a8d1b9191fc3..87e7513436a2 100644
--- a/app-text/calibre/calibre-0.8.66.ebuild
+++ b/app-text/calibre/calibre-0.8.68.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/calibre/calibre-0.8.66.ebuild,v 1.1 2012/08/24 20:28:26 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/calibre/calibre-0.8.68.ebuild,v 1.1 2012/09/07 20:17:54 zmedico Exp $
EAPI=4
PYTHON_DEPEND=2:2.7
@@ -26,6 +26,7 @@ COMMON_DEPEND="
>=dev-libs/chmlib-0.40
>=dev-libs/icu-4.4
>=dev-python/beautifulsoup-3.0.5:python-2
+ dev-python/netifaces
dev-python/python-dateutil
>=dev-python/dnspython-1.6.0
>=dev-python/cssutils-0.9.9
@@ -35,6 +36,7 @@ COMMON_DEPEND="
>=dev-python/mechanize-0.1.11
>=dev-python/python-dateutil-1.4.1
>=dev-python/PyQt4-4.9.1[X,svg,webkit]
+ media-fonts/liberation-fonts
>=media-gfx/imagemagick-6.5.9[jpeg,png]
>=media-libs/libwmf-0.2.8
media-libs/libmtp
@@ -156,6 +158,13 @@ src_install() {
rm -r "${ED}"usr/etc/bash_completion.d
find "${ED}"usr/etc -type d -empty -delete
+ cd "${ED}"/usr/share/calibre/fonts/liberation || die
+ local x
+ for x in * ; do
+ [[ -f ${EROOT}usr/share/fonts/liberation-fonts/${x} ]] || continue
+ ln -sf "../../../fonts/liberation-fonts/${x}" "${x}" || die
+ done
+
python_convert_shebangs -r $(python_get_version) "${ED}"
newinitd "${FILESDIR}"/calibre-server.init calibre-server