summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/iso-codes/ChangeLog8
-rw-r--r--app-text/iso-codes/iso-codes-3.19.ebuild49
-rw-r--r--app-text/iso-codes/iso-codes-3.21.ebuild49
-rw-r--r--app-text/iso-codes/iso-codes-3.24.2.ebuild (renamed from app-text/iso-codes/iso-codes-3.23.ebuild)4
4 files changed, 9 insertions, 101 deletions
diff --git a/app-text/iso-codes/ChangeLog b/app-text/iso-codes/ChangeLog
index 81cb9e7c54cb..23a552c3e66b 100644
--- a/app-text/iso-codes/ChangeLog
+++ b/app-text/iso-codes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/iso-codes
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.104 2011/03/22 18:48:25 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.105 2011/03/28 21:42:04 eva Exp $
+
+*iso-codes-3.24.2 (28 Mar 2011)
+
+ 28 Mar 2011; Gilles Dartiguelongue <eva@gentoo.org> -iso-codes-3.19.ebuild,
+ -iso-codes-3.21.ebuild, -iso-codes-3.23.ebuild, +iso-codes-3.24.2.ebuild:
+ Version bump with translation updates. Clean up old revisions.
22 Mar 2011; Brent Baude <ranger@gentoo.org> iso-codes-3.24.ebuild:
Marking iso-codes-3.24 ppc stable for bug 353436
diff --git a/app-text/iso-codes/iso-codes-3.19.ebuild b/app-text/iso-codes/iso-codes-3.19.ebuild
deleted file mode 100644
index f8e5ea616fa5..000000000000
--- a/app-text/iso-codes/iso-codes-3.19.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-3.19.ebuild,v 1.7 2010/10/29 03:20:52 jer Exp $
-
-EAPI="2"
-
-inherit eutils
-
-DESCRIPTION="Provides the list of country and language names"
-HOMEPAGE="http://alioth.debian.org/projects/pkg-isocodes/"
-SRC_URI="ftp://pkg-isocodes.alioth.debian.org/pub/pkg-isocodes/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE=""
-
-RDEPEND=""
-DEPEND="sys-devel/gettext"
-
-src_prepare() {
- local linguas_bak=${LINGUAS}
- local mylinguas=""
-
- for norm in iso_15924 iso_3166 iso_3166_2 iso_4217 iso_639 iso_639_3; do
- einfo "Preparing ${norm}"
-
- mylinguas=""
- LINGUAS=${linguas_bak}
- strip-linguas -i "${S}/${norm}"
-
- for loc in ${LINGUAS}; do
- mylinguas="${mylinguas} ${loc}.po"
- done
-
- if [ -n "${mylinguas}" ]; then
- sed -e "s:pofiles =.*:pofiles = ${mylinguas}:" \
- -e "s:mofiles =.*:mofiles = ${mylinguas//.po/.mo}:" \
- -i "${S}/${norm}/Makefile.am" "${S}/${norm}/Makefile.in" \
- || die "sed in ${norm} folder failed"
- fi
- done
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- dodoc ChangeLog README TODO || die "dodoc failed"
-}
diff --git a/app-text/iso-codes/iso-codes-3.21.ebuild b/app-text/iso-codes/iso-codes-3.21.ebuild
deleted file mode 100644
index be0b387a07d8..000000000000
--- a/app-text/iso-codes/iso-codes-3.21.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-3.21.ebuild,v 1.1 2010/10/05 03:34:05 leio Exp $
-
-EAPI="2"
-
-inherit eutils
-
-DESCRIPTION="Provides the list of country and language names"
-HOMEPAGE="http://alioth.debian.org/projects/pkg-isocodes/"
-SRC_URI="ftp://pkg-isocodes.alioth.debian.org/pub/pkg-isocodes/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~amd64-linux ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-linux ~x86-macos ~x86-solaris"
-IUSE=""
-
-RDEPEND=""
-DEPEND="sys-devel/gettext"
-
-src_prepare() {
- local linguas_bak=${LINGUAS}
- local mylinguas=""
-
- for norm in iso_15924 iso_3166 iso_3166_2 iso_4217 iso_639 iso_639_3; do
- einfo "Preparing ${norm}"
-
- mylinguas=""
- LINGUAS=${linguas_bak}
- strip-linguas -i "${S}/${norm}"
-
- for loc in ${LINGUAS}; do
- mylinguas="${mylinguas} ${loc}.po"
- done
-
- if [ -n "${mylinguas}" ]; then
- sed -e "s:pofiles =.*:pofiles = ${mylinguas}:" \
- -e "s:mofiles =.*:mofiles = ${mylinguas//.po/.mo}:" \
- -i "${S}/${norm}/Makefile.am" "${S}/${norm}/Makefile.in" \
- || die "sed in ${norm} folder failed"
- fi
- done
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- dodoc ChangeLog README TODO || die "dodoc failed"
-}
diff --git a/app-text/iso-codes/iso-codes-3.23.ebuild b/app-text/iso-codes/iso-codes-3.24.2.ebuild
index ad2bef2949ed..743a6598978a 100644
--- a/app-text/iso-codes/iso-codes-3.23.ebuild
+++ b/app-text/iso-codes/iso-codes-3.24.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-3.23.ebuild,v 1.1 2010/12/13 22:31:09 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-3.24.2.ebuild,v 1.1 2011/03/28 21:42:04 eva Exp $
EAPI="3"