summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/perl-support/perl-support-4.10.ebuild')
-rw-r--r--app-vim/perl-support/perl-support-4.10.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-vim/perl-support/perl-support-4.10.ebuild b/app-vim/perl-support/perl-support-4.10.ebuild
new file mode 100644
index 000000000000..3943c6786798
--- /dev/null
+++ b/app-vim/perl-support/perl-support-4.10.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/perl-support/perl-support-4.10.ebuild,v 1.1 2011/03/10 04:47:23 radhermit Exp $
+
+EAPI=3
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Perl-IDE - Write and run Perl scripts using menus and hotkeys"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=556"
+SRC_URI="http://www.vim.org/scripts/download_script.php?src_id=15126 -> ${P}.zip"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="perlsupport"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ # Don't set tabstop and shiftwidth
+ sed -i -e '/=4/s/^/"/' ftplugin/perl.vim
+}