summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/flamerobin/flamerobin-0.8.3.ebuild')
-rw-r--r--dev-db/flamerobin/flamerobin-0.8.3.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-db/flamerobin/flamerobin-0.8.3.ebuild b/dev-db/flamerobin/flamerobin-0.8.3.ebuild
deleted file mode 100644
index 38eb4607a631..000000000000
--- a/dev-db/flamerobin/flamerobin-0.8.3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/flamerobin/flamerobin-0.8.3.ebuild,v 1.3 2009/04/08 22:37:46 fauli Exp $
-
-EAPI=1
-
-inherit eutils wxwidgets
-
-DESCRIPTION="A database administration tool for Firebird DBMS"
-HOMEPAGE="http://www.flamerobin.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
-
-LICENSE="BSD as-is"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND="x11-libs/wxGTK:2.8
- dev-db/firebird"
-
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${P}-src"
-
-pkg_setup() {
- export WX_GTK_VER="2.6"
- need-wxwidgets gtk2
-}
-src_compile() {
- # temp hack since configure is not executable
- chmod +x configure
-
- local myconf
- myconf="${myconf} \
- --disable-shared \
- --disable-debug \
- --with-wx=yes \
- --with-wx-config=${WX_CONFIG}"
- econf ${myconf} || die "Could not configure FlameRobin"
- emake || die "error during make"
-}
-src_install() {
- make DESTDIR="${D}" install || die "Could not install FlameRobin"
-
- doicon "${S}"/res/fricon.xpm
- domenu "${FILESDIR}"/FlameRobin.desktop
-
- dodoc devdocs/* docs/* docs-src/*
-}