summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/hsqldb/hsqldb-1.8.1.2.ebuild')
-rw-r--r--dev-db/hsqldb/hsqldb-1.8.1.2.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-db/hsqldb/hsqldb-1.8.1.2.ebuild b/dev-db/hsqldb/hsqldb-1.8.1.2.ebuild
index 9e0e8fbf6e7e..8b8b0ebc5e26 100644
--- a/dev-db/hsqldb/hsqldb-1.8.1.2.ebuild
+++ b/dev-db/hsqldb/hsqldb-1.8.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/hsqldb/hsqldb-1.8.1.2.ebuild,v 1.1 2010/03/09 10:31:28 ali_bush Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hsqldb/hsqldb-1.8.1.2.ebuild,v 1.2 2010/04/05 22:31:38 caster Exp $
EAPI=1
JAVA_PKG_IUSE="doc source test"
@@ -119,15 +119,15 @@ src_install() {
exeinto "${HSQLDB_HOME}/bin"
doexe bin/hsqldb || die
+ # Make sure that files have correct permissions
+ chown -R hsqldb:hsqldb "${D}${HSQLDB_HOME}"
+ chmod o-rwx "${D}${HSQLDB_HOME}"
+
# Create symlinks to authorization files in the server home dir
# (required by the hqldb init script)
insinto "${HSQLDB_HOME}"
dosym /etc/hsqldb/server.properties "${HSQLDB_HOME}/server.properties" || die
dosym /etc/hsqldb/sqltool.rc "${HSQLDB_HOME}/sqltool.rc" || die
-
- # Make sure that files have correct permissions
- chown -R hsqldb:hsqldb "${D}${HSQLDB_HOME}"
- chmod o-rwx "${D}${HSQLDB_HOME}"
}
pkg_postinst() {