summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/mysql-connector-c/files/conn-c-includes.patch')
-rw-r--r--dev-db/mysql-connector-c/files/conn-c-includes.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/dev-db/mysql-connector-c/files/conn-c-includes.patch b/dev-db/mysql-connector-c/files/conn-c-includes.patch
new file mode 100644
index 000000000000..fcde71f3f4ee
--- /dev/null
+++ b/dev-db/mysql-connector-c/files/conn-c-includes.patch
@@ -0,0 +1,15 @@
+diff -aurN a/include/CMakeLists.txt b/include/CMakeLists.txt
+--- a/include/CMakeLists.txt 2015-07-14 13:06:04.424091000 -0400
++++ b/include/CMakeLists.txt 2015-07-14 13:24:43.434091000 -0400
+@@ -55,6 +55,11 @@
+ byte_order_generic_x86.h
+ little_endian.h
+ big_endian.h
++ my_thread_local.h
++ thr_cond.h
++ thr_lock.h
++ thr_mutex.h
++ thr_rwlock.h
+ ${HEADERS_GEN_CONFIGURE}
+ )
+