summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/mysql/mysql-5.0.84-r1.ebuild')
-rw-r--r--dev-db/mysql/mysql-5.0.84-r1.ebuild30
1 files changed, 28 insertions, 2 deletions
diff --git a/dev-db/mysql/mysql-5.0.84-r1.ebuild b/dev-db/mysql/mysql-5.0.84-r1.ebuild
index f7614bc002ff..6e6f90c2ef2a 100644
--- a/dev-db/mysql/mysql-5.0.84-r1.ebuild
+++ b/dev-db/mysql/mysql-5.0.84-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.84-r1.ebuild,v 1.9 2009/11/29 18:13:17 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.84-r1.ebuild,v 1.10 2010/01/31 22:33:37 robbat2 Exp $
MY_EXTRAS_VER="20090908-1245Z"
EAPI=2
@@ -115,6 +115,32 @@ src_test() {
done
;;
esac
+
+ # The entire 5.0 series has pre-generated SSL certificates, they have
+ # mostly expired now. ${S}/mysql-tests/std-data/*.pem
+ # The certs really SHOULD be generated for the tests, so that they are
+ # not expiring like this. We cannot do so ourselves as the tests look
+ # closely as the cert path data, and we do not have the CA key to regen
+ # ourselves. Alternatively, upstream should generate them with at least
+ # 50-year validity.
+ #
+ # Known expiry points:
+ # 4.1.*, 5.0.0-5.0.22, 5.1.7: Expires 2013/09/09
+ # 5.0.23-5.0.77, 5.1.7-5.1.22?: Expires 2009/01/27
+ # 5.0.78-5.0.90, 5.1.??-5.1.42: Expires 2010/01/28
+ #
+ # mysql-test/std_data/untrusted-cacert.pem is MEANT to be
+ # expired/invalid.
+ case ${PV} in
+ 5.0.*|5.1.*)
+ for t in openssl_1 rpl_openssl rpl_ssl ssl ssl_8k_key \
+ ssl_compress ssl_connect ; do \
+ mysql_disable_test \
+ "$t" \
+ "These OpenSSL tests break due to expired certificates"
+ done
+ ;;
+ esac
# create directories because mysqladmin might right out of order
mkdir -p "${S}"/mysql-test/var-{ps,ns}{,/log}