summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/sqlite/sqlite-3.2.1-r3.ebuild')
-rw-r--r--dev-db/sqlite/sqlite-3.2.1-r3.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/dev-db/sqlite/sqlite-3.2.1-r3.ebuild b/dev-db/sqlite/sqlite-3.2.1-r3.ebuild
index b5167b2cdcc3..2f5c1c5b93e3 100644
--- a/dev-db/sqlite/sqlite-3.2.1-r3.ebuild
+++ b/dev-db/sqlite/sqlite-3.2.1-r3.ebuild
@@ -1,31 +1,27 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.2.1-r3.ebuild,v 1.1 2005/04/24 20:53:44 arj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.2.1-r3.ebuild,v 1.1.1.1 2005/11/30 10:11:35 chriswhite Exp $
inherit eutils
-IUSE="nothreadsafe doc"
-
-DESCRIPTION="SQLite: An SQL Database Engine in a C Library."
+DESCRIPTION="SQLite: An SQL Database Engine in a C Library"
+HOMEPAGE="http://www.sqlite.org/"
SRC_URI="http://www.sqlite.org/${P}.tar.gz"
-HOMEPAGE="http://www.sqlite.org"
-# Adding glibc as dependency for USE !nothreadsafe until someone can tell me
-# if all virtual/libc's provide POSIX threads (pthread.h)
-# - 20041203, Armando Di Cianno <fafhrd@gentoo.org>
-DEPEND="virtual/libc
- !nothreadsafe? ( !ppc-macos? ( sys-libs/glibc ) )
- doc? (dev-lang/tcl)"
-SLOT="3"
LICENSE="as-is"
+SLOT="3"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ~ppc-macos ppc64 sparc x86"
+IUSE="nothreadsafe doc"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc-macos ~sparc ~x86 ~ppc64"
+DEPEND="virtual/libc
+ doc? ( dev-lang/tcl )"
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${P}-data-corruption.patch
epatch ${FILESDIR}/${P}-tcl-fix.patch
+ epunt_cxx
}
src_compile() {