summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/unixODBC/unixODBC-2.0.8.ebuild')
-rw-r--r--dev-db/unixODBC/unixODBC-2.0.8.ebuild63
1 files changed, 30 insertions, 33 deletions
diff --git a/dev-db/unixODBC/unixODBC-2.0.8.ebuild b/dev-db/unixODBC/unixODBC-2.0.8.ebuild
index cc5309c95ca0..943ef4340582 100644
--- a/dev-db/unixODBC/unixODBC-2.0.8.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.0.8.ebuild
@@ -1,46 +1,43 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.8.ebuild,v 1.1 2001/07/01 21:56:57 achim Exp $
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.8.ebuild,v 1.1.1.1 2005/11/30 10:11:40 chriswhite Exp $
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
DESCRIPTION="ODBC Interface for Linux"
-SRC_URI="http://www.unixodbc.org/${A}"
-HOMEPAGE="http://www.unixodbc.org"
+HOMEPAGE="http://www.unixodbc.org/"
+SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
-DEPEND="virtual/glibc
- >=sys-libs/readline-4.1
- >=sys-libs/ncurses-5.2
- qt? ( >=x11-libs/qt-x11-2.3.0 )"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~hppa ~alpha"
+IUSE=""
-src_unpack() {
-
- unpack ${A}
- cd ${S}
- cp Makefile.in Makefile.orig
- sed -e "s:touch :touch \${DESTDIR}/:" Makefile.orig > Makefile.in
+DEPEND="virtual/libc
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp Makefile.in Makefile.orig
+ sed -e "s:touch :touch \${DESTDIR}/:" Makefile.orig > Makefile.in
}
+
src_compile() {
- local myconf
- if [ "`use qt`" ]
- then
- myconf="--enable-gui=yes"
- else
- myconf="--enable-gui=no"
- fi
- try ./configure --prefix=/usr --sysconfdir=/etc/unixODBC --host=${CHOST} ${myconf}
+ local myconf="--enable-gui=no"
- try make
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
+ ${myconf} || die
+ make || die
}
-src_install () {
+src_install() {
+ make DESTDIR=${D} install || die
- try make DESTDIR=${D} install
- dodoc AUTHORS COPYING ChangeLog NEWS README*
- cp -a doc ${D}/usr/share/doc/${PF}/html
- find ${D}/usr/share/doc/${PF}/html -name "Makefile*" -exec rm {} \;
- prepalldocs
+ dodoc AUTHORS COPYING ChangeLog NEWS README*
+ find doc/ -name "Makefile*" -exec rm '{}' \;
+ dohtml doc/*
+ prepalldocs
}