summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql++/ChangeLog5
-rw-r--r--dev-db/mysql++/mysql++-3.0.9.ebuild8
2 files changed, 8 insertions, 5 deletions
diff --git a/dev-db/mysql++/ChangeLog b/dev-db/mysql++/ChangeLog
index de6ffb0f41b5..fde5924c19d4 100644
--- a/dev-db/mysql++/ChangeLog
+++ b/dev-db/mysql++/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-db/mysql++
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/ChangeLog,v 1.61 2009/09/11 21:01:28 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/ChangeLog,v 1.62 2009/12/23 15:37:48 grobian Exp $
+
+ 23 Dec 2009; Fabian Groffen <grobian@gentoo.org> mysql++-3.0.9.ebuild:
+ Fix for Prefix, marked ~amd64-linux and ~ppc-macos, bug #294611
*mysql++-3.0.9 (11 Sep 2009)
diff --git a/dev-db/mysql++/mysql++-3.0.9.ebuild b/dev-db/mysql++/mysql++-3.0.9.ebuild
index 9cd9f565045c..12120523c01b 100644
--- a/dev-db/mysql++/mysql++-3.0.9.ebuild
+++ b/dev-db/mysql++/mysql++-3.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/mysql++-3.0.9.ebuild,v 1.1 2009/09/11 21:01:28 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/mysql++-3.0.9.ebuild,v 1.2 2009/12/23 15:37:48 grobian Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="http://www.tangentsoft.net/mysql++/releases/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="3"
-KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~ppc-macos"
IUSE=""
RDEPEND=">=virtual/mysql-4.0"
@@ -34,7 +34,7 @@ src_unpack() {
src_compile() {
local myconf
- myconf="--enable-thread-check"
+ myconf="--enable-thread-check --with-mysql=${EPREFIX}/usr"
CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
econf ${myconf} || die "econf failed"
@@ -47,6 +47,6 @@ src_install() {
# install the docs and HTML pages
dodoc README* CREDITS* ChangeLog HACKERS Wishlist
dodoc doc/*
- cp -ra doc/html "${D}"/usr/share/doc/${PF}/html
+ cp -ra doc/html "${D%/}${EPREFIX}"/usr/share/doc/${PF}/html
prepalldocs
}