summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/crypto-conduit/crypto-conduit-0.5.2.2.ebuild')
-rw-r--r--dev-haskell/crypto-conduit/crypto-conduit-0.5.2.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/crypto-conduit/crypto-conduit-0.5.2.2.ebuild b/dev-haskell/crypto-conduit/crypto-conduit-0.5.2.2.ebuild
new file mode 100644
index 000000000000..7b48a688bc9a
--- /dev/null
+++ b/dev-haskell/crypto-conduit/crypto-conduit-0.5.2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto-conduit/crypto-conduit-0.5.2.2.ebuild,v 1.1 2014/03/09 12:37:26 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+#hackport: flags: -old-crypto-api
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Conduit interface for cryptographic operations (from crypto-api)."
+HOMEPAGE="https://github.com/meteficha/crypto-conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cereal-0.3:=[profile?] <dev-haskell/cereal-0.5:=[profile?]
+ >=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.1:=[profile?]
+ >=dev-haskell/crypto-api-0.9:=[profile?] <dev-haskell/crypto-api-0.14:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/cryptocipher-0.4
+ >=dev-haskell/cryptohash-cryptoapi-0.1
+ >=dev-haskell/hspec-1.3
+ >=dev-haskell/skein-0.1 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-old-crypto-api
+}