summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/testpack')
-rw-r--r--dev-haskell/testpack/ChangeLog11
-rw-r--r--dev-haskell/testpack/metadata.xml15
-rw-r--r--dev-haskell/testpack/testpack-2.1.0.ebuild26
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-haskell/testpack/ChangeLog b/dev-haskell/testpack/ChangeLog
new file mode 100644
index 000000000000..d07802f92629
--- /dev/null
+++ b/dev-haskell/testpack/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-haskell/testpack
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/testpack/ChangeLog,v 1.1 2011/06/12 12:22:55 slyfox Exp $
+
+*testpack-2.1.0 (12 Jun 2011)
+
+ 12 Jun 2011; Sergei Trofimovich <slyfox@gentoo.org> +testpack-2.1.0.ebuild,
+ +metadata.xml:
+ Initial version. New package: library with testing interface to HUnit and
+ QuickCheck.
+
diff --git a/dev-haskell/testpack/metadata.xml b/dev-haskell/testpack/metadata.xml
new file mode 100644
index 000000000000..a68bb9be4abb
--- /dev/null
+++ b/dev-haskell/testpack/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Testpack provides utilities for both HUnit and QuickCheck. These include
+ tools for running QuickCheck properties as HUnit test cases, allowing you to
+ combine both approaches in a single program. It also includes tools for more
+ helpful displays of running progress in both HUnit and QuickCheck, additional
+ generators for other types for QuickCheck, and shortcuts for quickly defining new.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/testpack/testpack-2.1.0.ebuild b/dev-haskell/testpack/testpack-2.1.0.ebuild
new file mode 100644
index 000000000000..c384aab0c2fc
--- /dev/null
+++ b/dev-haskell/testpack/testpack-2.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/testpack/testpack-2.1.0.ebuild,v 1.1 2011/06/12 12:22:55 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+CABAL_FEATURES="lib profile haddock hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Test Utililty Pack for HUnit and QuickCheck"
+HOMEPAGE="http://hackage.haskell.org/cgi-bin/hackage-scripts/package/testpack"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/hunit
+ dev-haskell/mtl
+ >=dev-haskell/quickcheck-2.1.0.3
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"