summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/pcre-light/ChangeLog8
-rw-r--r--dev-haskell/pcre-light/files/pcre-light-0.4-ghc-7.7.patch39
-rw-r--r--dev-haskell/pcre-light/pcre-light-0.4-r1.ebuild28
3 files changed, 74 insertions, 1 deletions
diff --git a/dev-haskell/pcre-light/ChangeLog b/dev-haskell/pcre-light/ChangeLog
index 190d1bc3bba4..73118a0421f1 100644
--- a/dev-haskell/pcre-light/ChangeLog
+++ b/dev-haskell/pcre-light/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/pcre-light
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/pcre-light/ChangeLog,v 1.3 2013/07/21 17:21:57 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/pcre-light/ChangeLog,v 1.4 2013/10/19 12:29:31 gienah Exp $
+
+*pcre-light-0.4-r1 (19 Oct 2013)
+
+ 19 Oct 2013; Mark Wright <gienah@gentoo.org>
+ +files/pcre-light-0.4-ghc-7.7.patch, +pcre-light-0.4-r1.ebuild:
+ Patch pcre-light for >=ghc-7.7
21 Jul 2013; Christoph Junghans <ottxor@gentoo.org> pcre-light-0.4.ebuild:
added ~amd64-linux (tested by me)
diff --git a/dev-haskell/pcre-light/files/pcre-light-0.4-ghc-7.7.patch b/dev-haskell/pcre-light/files/pcre-light-0.4-ghc-7.7.patch
new file mode 100644
index 000000000000..2b4181929f60
--- /dev/null
+++ b/dev-haskell/pcre-light/files/pcre-light-0.4-ghc-7.7.patch
@@ -0,0 +1,39 @@
+diff --git a/Text/Regex/PCRE/Light.hs b/Text/Regex/PCRE/Light.hs
+index 80c28a0..7fc9581 100644
+--- a/Text/Regex/PCRE/Light.hs
++++ b/Text/Regex/PCRE/Light.hs
+@@ -77,6 +77,7 @@ import qualified Data.ByteString as S
+ #if __GLASGOW_HASKELL__ >= 608
+ import qualified Data.ByteString.Internal as S
+ import qualified Data.ByteString.Unsafe as S
++import qualified System.IO.Unsafe as U
+ #else
+ import qualified Data.ByteString.Base as S
+ #endif
+@@ -193,7 +194,7 @@ compile s o = case compileM s o of
+ -- > Left "nothing to repeat"
+ --
+ compileM :: S.ByteString -> [PCREOption] -> Either String Regex
+-compileM str os = unsafePerformIO $
++compileM str os = U.unsafePerformIO $
+ S.useAsCString str $ \pattern -> do
+ alloca $ \errptr -> do
+ alloca $ \erroffset -> do
+@@ -263,7 +264,7 @@ compileM str os = unsafePerformIO $
+ -- is returned.
+ --
+ match :: Regex -> S.ByteString -> [PCREExecOption] -> Maybe [S.ByteString]
+-match (Regex pcre_fp _) subject os = unsafePerformIO $ do
++match (Regex pcre_fp _) subject os = U.unsafePerformIO $ do
+ withForeignPtr pcre_fp $ \pcre_ptr -> do
+ n_capt <- captureCount' pcre_ptr
+
+@@ -324,7 +325,7 @@ match (Regex pcre_fp _) subject os = unsafePerformIO $ do
+
+
+ captureCount :: Regex -> Int
+-captureCount (Regex pcre_fp _) = unsafePerformIO $ do
++captureCount (Regex pcre_fp _) = U.unsafePerformIO $ do
+ withForeignPtr pcre_fp $ \pcre_ptr -> do
+ captureCount' pcre_ptr
+
diff --git a/dev-haskell/pcre-light/pcre-light-0.4-r1.ebuild b/dev-haskell/pcre-light/pcre-light-0.4-r1.ebuild
new file mode 100644
index 000000000000..8df92763d97c
--- /dev/null
+++ b/dev-haskell/pcre-light/pcre-light-0.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/pcre-light/pcre-light-0.4-r1.ebuild,v 1.1 2013/10/19 12:29:31 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="A small, efficient and portable regex library for Perl 5 compatible regular expressions"
+HOMEPAGE="http://code.haskell.org/~dons/code/pcre-light"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:=
+ dev-libs/libpcre
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+PATCHES=("${FILESDIR}"/${P}-ghc-7.7.patch)