summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/mercury')
-rw-r--r--dev-lang/mercury/ChangeLog7
-rw-r--r--dev-lang/mercury/files/mercury-0.13.1-tests-declarative-throw.patch57
-rw-r--r--dev-lang/mercury/mercury-0.13.1-r1.ebuild4
3 files changed, 66 insertions, 2 deletions
diff --git a/dev-lang/mercury/ChangeLog b/dev-lang/mercury/ChangeLog
index e99af0bb3708..3b05f4ed0da9 100644
--- a/dev-lang/mercury/ChangeLog
+++ b/dev-lang/mercury/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/mercury
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/ChangeLog,v 1.80 2007/10/15 06:05:08 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/ChangeLog,v 1.81 2007/10/20 03:28:17 keri Exp $
+
+ 20 Oct 2007; keri <keri@gentoo.org>
+ +files/mercury-0.13.1-tests-declarative-throw.patch,
+ mercury-0.13.1-r1.ebuild:
+ Fix missing trace path on declarative debugging tests.
15 Oct 2007; keri <keri@gentoo.org> files/mercury-0.13.1-bootstrap.patch:
Regenerate slice C files when bootstrap stage1 grade is different from
diff --git a/dev-lang/mercury/files/mercury-0.13.1-tests-declarative-throw.patch b/dev-lang/mercury/files/mercury-0.13.1-tests-declarative-throw.patch
new file mode 100644
index 000000000000..0a78c5ef8a4b
--- /dev/null
+++ b/dev-lang/mercury/files/mercury-0.13.1-tests-declarative-throw.patch
@@ -0,0 +1,57 @@
+diff -urN mercury-tests-0.13.1.orig/debugger/declarative/throw.exp4 mercury-tests-0.13.1/debugger/declarative/throw.exp4
+--- mercury-tests-0.13.1.orig/debugger/declarative/throw.exp4 1970-01-01 12:00:00.000000000 +1200
++++ mercury-tests-0.13.1/debugger/declarative/throw.exp4 2007-10-20 14:56:07.000000000 +1300
+@@ -0,0 +1,53 @@
++ E1: C1 CALL pred throw.main/2-0 (cc_multi) throw.m:10
++mdb> echo on
++Command echo enabled.
++mdb> register --quiet
++mdb> break p
++ 0: + stop interface pred throw.p/1-0 (cc_nondet)
++mdb> break q
++ 1: + stop interface pred throw.q/1-0 (semidet)
++mdb> continue
++ E2: C2 CALL pred throw.p/1-0 (cc_nondet) throw.m:20
++mdb> finish
++ E3: C2 EXCP pred throw.p/1-0 (cc_nondet)
++mdb> dd -d 3 -n 7
++Call p(_)
++Throws "Too big"
++Expected? no
++a(3)
++Valid? yes
++Call b(3, _)
++Throws "Too big"
++Expected? yes
++Found unhandled or incorrect exception:
++p(_)
++"Too big"
++Is this a bug? yes
++ E3: C2 EXCP pred throw.p/1-0 (cc_nondet)
++mdb> continue
++mdb: warning: reached unknown label
++This may result in some exception events
++being omitted from the trace.
++exception(univ_cons("Too big"))
++ E4: C3 CALL pred throw.q/1-0 (semidet) throw.m:48
++mdb> finish
++ E5: C3 EXCP pred throw.q/1-0 (semidet)
++mdb> dd -d 3 -n 7
++Call q(_)
++Throws "Too big"
++Expected? no
++a2(3)
++Valid? yes
++Call b2(3, _)
++Throws "Too big"
++Expected? yes
++Found unhandled or incorrect exception:
++q(_)
++"Too big"
++Is this a bug? yes
++ E5: C3 EXCP pred throw.q/1-0 (semidet)
++mdb> continue
++mdb: warning: reached unknown label
++This may result in some exception events
++being omitted from the trace.
++exception(univ_cons("Too big"))
diff --git a/dev-lang/mercury/mercury-0.13.1-r1.ebuild b/dev-lang/mercury/mercury-0.13.1-r1.ebuild
index 6ffefdb5e5d6..0d4aaebcaff3 100644
--- a/dev-lang/mercury/mercury-0.13.1-r1.ebuild
+++ b/dev-lang/mercury/mercury-0.13.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-0.13.1-r1.ebuild,v 1.9 2007/03/02 23:43:00 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-0.13.1-r1.ebuild,v 1.10 2007/10/20 03:28:17 keri Exp $
inherit eutils
@@ -34,6 +34,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-parallel-install_grades.patch
epatch "${FILESDIR}"/${P}-deep_profiler.patch
epatch "${FILESDIR}"/${P}-docs.patch
+ epatch "${FILESDIR}"/${P}-tests-declarative-throw.patch
epatch "${FILESDIR}"/${P}-tests-dir_test.patch
epatch "${FILESDIR}"/${P}-tests-ho_and_type_spec_bug.patch
epatch "${FILESDIR}"/${P}-tests-mdbrc.patch
@@ -103,6 +104,7 @@ src_test() {
sed -i -e "s:@WORKSPACE@:${TWS}:" WS_FLAGS.ws
PATH="${TWS}"/scripts:"${TWS}"/util:"${PATH}" \
+ TERM="" \
WORKSPACE="${TWS}" \
MERCURY_COMPILER="${TWS}"/compiler/mercury_compile \
MMAKE_DIR="${TWS}"/scripts \