summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/yap')
-rw-r--r--dev-lang/yap/ChangeLog6
-rw-r--r--dev-lang/yap/files/yap-5.1.1-jpl.patch47
-rw-r--r--dev-lang/yap/yap-5.1.1.ebuild7
3 files changed, 56 insertions, 4 deletions
diff --git a/dev-lang/yap/ChangeLog b/dev-lang/yap/ChangeLog
index 721f49553428..24a7199e6195 100644
--- a/dev-lang/yap/ChangeLog
+++ b/dev-lang/yap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/yap
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yap/ChangeLog,v 1.13 2007/01/23 18:19:00 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yap/ChangeLog,v 1.14 2007/02/03 04:41:14 keri Exp $
+
+ 03 Feb 2007; keri <keri@gentoo.org> +files/yap-5.1.1-jpl.patch,
+ yap-5.1.1.ebuild:
+ Ensure jdk VM is found for JPL package.
23 Jan 2007; nixnut <nixnut@gentoo.org> yap-5.1.1.ebuild:
Stable on ppc wrt bug 163123
diff --git a/dev-lang/yap/files/yap-5.1.1-jpl.patch b/dev-lang/yap/files/yap-5.1.1-jpl.patch
new file mode 100644
index 000000000000..72b0e5f51602
--- /dev/null
+++ b/dev-lang/yap/files/yap-5.1.1-jpl.patch
@@ -0,0 +1,47 @@
+--- Yap-5.1.1.orig/LGPL/JPL/src/jpl.c 2006-02-02 02:28:56.000000000 +1300
++++ Yap-5.1.1/LGPL/JPL/src/jpl.c 2007-02-03 17:16:56.000000000 +1300
+@@ -1827,7 +1827,7 @@
+
+
+ //=== JVM initialisation, startup etc. =============================================================
+-
++/*
+ // this isn't much use; it can't discover JDK 1.2 support...
+ static int
+ jni_supported_jvm_version(
+@@ -1848,7 +1848,7 @@
+ && minor == mlo
+ ;
+ }
+-
++*/
+
+ static int
+ jni_get_created_jvm_count(void)
+@@ -1930,7 +1930,7 @@
+ );
+ }
+
+-
++/*
+ static foreign_t
+ jni_supported_jvm_version_plc( // not as useful as I'd hoped...
+ term_t t1,
+@@ -1945,7 +1945,7 @@
+ && jni_supported_jvm_version(major,minor)
+ ;
+ }
+-
++*/
+
+ static foreign_t
+ jni_get_created_jvm_count_plc(
+@@ -3879,7 +3879,7 @@
+ static
+ PL_extension predspecs[] =
+ { { "jni_create_jvm", 2, jni_create_jvm_plc, 0 },
+- { "jni_supported_jvm_version", 2, jni_supported_jvm_version_plc, 0 },
++/* { "jni_supported_jvm_version", 2, jni_supported_jvm_version_plc, 0 },*/
+ { "jni_get_created_jvm_count", 1, jni_get_created_jvm_count_plc, 0 },
+ { "jni_ensure_jvm", 0, jni_ensure_jvm_plc, 0 },
+ { "jni_tag_to_iref", 2, jni_tag_to_iref_plc, 0 },
diff --git a/dev-lang/yap/yap-5.1.1.ebuild b/dev-lang/yap/yap-5.1.1.ebuild
index 2d3357f53b2c..6871228a3f78 100644
--- a/dev-lang/yap/yap-5.1.1.ebuild
+++ b/dev-lang/yap/yap-5.1.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yap/yap-5.1.1.ebuild,v 1.9 2007/01/23 18:19:00 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yap/yap-5.1.1.ebuild,v 1.10 2007/02/03 04:41:14 keri Exp $
-inherit autotools eutils
+inherit autotools eutils java-pkg-opt-2
MY_P="Yap-${PV}"
@@ -16,7 +16,7 @@ KEYWORDS="~amd64 ppc x86"
IUSE="debug doc examples gmp java mpi mysql odbc readline static tk threads"
DEPEND="gmp? ( dev-libs/gmp )
- java? ( virtual/jdk )
+ java? ( >=virtual/jdk-1.4 )
mpi? ( virtual/mpi )
mysql? ( virtual/mysql )
odbc? ( dev-db/unixODBC )
@@ -36,6 +36,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-analyst.patch
epatch "${FILESDIR}"/${P}-myddas.patch
epatch "${FILESDIR}"/${P}-tabling.patch
+ epatch "${FILESDIR}"/${P}-jpl.patch
epatch "${FILESDIR}"/${P}-tkyap.patch
}