summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/check')
-rw-r--r--dev-libs/check/ChangeLog8
-rw-r--r--dev-libs/check/check-0.9.5.ebuild20
-rw-r--r--dev-libs/check/files/check-0.9.5-autotools.patch14
3 files changed, 29 insertions, 13 deletions
diff --git a/dev-libs/check/ChangeLog b/dev-libs/check/ChangeLog
index 433819f8a1b5..cd242fcfcbc9 100644
--- a/dev-libs/check/ChangeLog
+++ b/dev-libs/check/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/check
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/check/ChangeLog,v 1.32 2006/12/14 16:24:47 twp Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/check/ChangeLog,v 1.33 2006/12/28 19:52:08 vapier Exp $
+
+ 28 Dec 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/check-0.9.5-autotools.patch, check-0.9.5.ebuild:
+ Cleanup autotools.
14 Dec 2006; <twp@gentoo.org> check-0.9.5.ebuild:
Install docs in correct dir.
diff --git a/dev-libs/check/check-0.9.5.ebuild b/dev-libs/check/check-0.9.5.ebuild
index 5bd91f9db0e3..33622ac313ef 100644
--- a/dev-libs/check/check-0.9.5.ebuild
+++ b/dev-libs/check/check-0.9.5.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/check/check-0.9.5.ebuild,v 1.2 2006/12/14 16:24:47 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/check/check-0.9.5.ebuild,v 1.3 2006/12/28 19:52:08 vapier Exp $
-inherit autotools eutils libtool
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+inherit eutils autotools
DESCRIPTION="A unit test framework for C"
HOMEPAGE="http://sourceforge.net/projects/check/"
@@ -17,16 +19,12 @@ DEPEND=""
src_unpack() {
unpack ${A}
- elibtoolize || die
-}
-
-src_compile() {
- eautoreconf || die
- econf || die
- emake || die
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ eautoreconf
}
src_install() {
- make DESTDIR="${D}" install || die
- mv ${D}/usr/share/doc/${PN} ${D}/usr/share/doc/${P}
+ emake DESTDIR="${D}" install || die
+ mv "${D}"/usr/share/doc/{${PN},${PF}} || die
}
diff --git a/dev-libs/check/files/check-0.9.5-autotools.patch b/dev-libs/check/files/check-0.9.5-autotools.patch
new file mode 100644
index 000000000000..f146c03a6eef
--- /dev/null
+++ b/dev-libs/check/files/check-0.9.5-autotools.patch
@@ -0,0 +1,14 @@
+Needed with newer autotools:
+
+tests/Makefile.am:22: compiling `check_list.c' with per-target flags requires `AM_PROG_CC_C_O' in `configure.ac'
+
+--- configure.ac
++++ configure.ac
+@@ -68,6 +68,7 @@
+ # Checks for programs.
+ AC_PROG_AWK
+ AC_PROG_CC
++AM_PROG_CC_C_O
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_LIBTOOL