summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/elfutils')
-rw-r--r--dev-libs/elfutils/ChangeLog6
-rw-r--r--dev-libs/elfutils/elfutils-0.153.ebuild7
2 files changed, 9 insertions, 4 deletions
diff --git a/dev-libs/elfutils/ChangeLog b/dev-libs/elfutils/ChangeLog
index fae9fe354ae9..5c0def30dfff 100644
--- a/dev-libs/elfutils/ChangeLog
+++ b/dev-libs/elfutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/elfutils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.159 2012/02/28 21:52:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.160 2012/04/16 22:53:57 vapier Exp $
+
+ 16 Apr 2012; Mike Frysinger <vapier@gentoo.org> elfutils-0.153.ebuild:
+ Make sure to apppend -g to CFLAGS when running tests as the local testsuite
+ depends on it to pass #407135 by Chris Reffett.
28 Feb 2012; Mike Frysinger <vapier@gentoo.org> elfutils-0.153.ebuild:
Drop cross-compiling hacks now that upstream has updated things.
diff --git a/dev-libs/elfutils/elfutils-0.153.ebuild b/dev-libs/elfutils/elfutils-0.153.ebuild
index b07b8c35a05c..1ea07492e94e 100644
--- a/dev-libs/elfutils/elfutils-0.153.ebuild
+++ b/dev-libs/elfutils/elfutils-0.153.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/elfutils-0.153.ebuild,v 1.2 2012/02/28 21:52:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/elfutils-0.153.ebuild,v 1.3 2012/04/16 22:53:58 vapier Exp $
EAPI="3"
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)"
HOMEPAGE="https://fedorahosted.org/elfutils/"
@@ -15,7 +15,7 @@ SRC_URI="https://fedorahosted.org/releases/e/l/${PN}/${PV}/${P}.tar.bz2
LICENSE="GPL-2-with-exceptions"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 lzma nls zlib"
+IUSE="bzip2 lzma nls test zlib"
# This pkg does not actually seem to compile currently in a uClibc
# environment (xrealloc errs), but we need to ensure that glibc never
@@ -39,6 +39,7 @@ src_prepare() {
}
src_configure() {
+ use test && append-flags -g #407135
econf \
$(use_enable nls) \
--program-prefix="eu-" \