summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/glib/glib-2.0.4-r1.ebuild')
-rw-r--r--dev-libs/glib/glib-2.0.4-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/glib/glib-2.0.4-r1.ebuild b/dev-libs/glib/glib-2.0.4-r1.ebuild
new file mode 100644
index 000000000000..c152ee58760f
--- /dev/null
+++ b/dev-libs/glib/glib-2.0.4-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Spider <spider@gentoo.org>
+# Maintainer: Spider <spider@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.0.4-r1.ebuild,v 1.1 2002/06/30 00:40:57 azarah Exp $
+
+inherit debug
+inherit libtool
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The GLib library of C routines"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.0/${P}.tar.bz2"
+HOMEPAGE="http://www.gtk.org/"
+LICENSE="LGPL-2.1"
+SLOT="2"
+
+DEPEND="virtual/glibc
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9-r2 )"
+
+
+# libiconv breaks other stuff
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ # Seems libtool have another wierd bug, try to fix it
+ # with a fix for nautilus, bug #4190
+ elibtoolize --reverse-deps
+
+ local myconf=""
+ use doc && myconf="${myconf} --enable-gtk-doc"
+ use doc || myconf="${myconf} --disable-gtk-doc"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-threads=posix \
+ ${myconf} \
+ --enable-debug=yes || die
+
+# you cannot disable debug or this will fail building.
+# odd but true :/
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS NEWS.pre-1-3 TODO.xml
+}
+
+
+
+
+