summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-cclan/cl-cclan-1.78.ebuild')
-rw-r--r--dev-lisp/cl-cclan/cl-cclan-1.78.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-lisp/cl-cclan/cl-cclan-1.78.ebuild b/dev-lisp/cl-cclan/cl-cclan-1.78.ebuild
new file mode 100644
index 000000000000..0d61c86c63bb
--- /dev/null
+++ b/dev-lisp/cl-cclan/cl-cclan-1.78.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-cclan/cl-cclan-1.78.ebuild,v 1.1 2003/10/15 21:03:58 mkennedy Exp $
+
+inherit common-lisp
+
+DEB_PV=1
+
+DESCRIPTION="Comprehensive Common Lisp Archive Network"
+HOMEPAGE="http://cclan.sourceforge.net
+ http://www.cliki.net/cclan
+ http://packages.debian.org/unstable/devel/cl-cclan.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-asdf/cl-asdf_${PV}-${DEB_PV}.diff.gz
+ http://ftp.debian.org/debian/pool/main/c/cl-asdf/cl-asdf_${PV}.orig.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lisp/cl-asdf
+ virtual/commonlisp
+ dev-lisp/common-lisp-controller"
+
+CLPACKAGE=cclan
+
+S=${WORKDIR}/cl-asdf-${PV}
+
+src_unpack() {
+ unpack ${A}
+ epatch cl-asdf_${PV}-${DEB_PV}.diff
+}
+
+src_install() {
+ common-lisp-install cclan*.lisp cclan.asd
+ common-lisp-system-symlink
+ do-debian-credits
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}