summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-htmlgen/cl-htmlgen-1.2.35.20040804.ebuild')
-rw-r--r--dev-lisp/cl-htmlgen/cl-htmlgen-1.2.35.20040804.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-lisp/cl-htmlgen/cl-htmlgen-1.2.35.20040804.ebuild b/dev-lisp/cl-htmlgen/cl-htmlgen-1.2.35.20040804.ebuild
new file mode 100644
index 000000000000..4af91298ec48
--- /dev/null
+++ b/dev-lisp/cl-htmlgen/cl-htmlgen-1.2.35.20040804.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-htmlgen/cl-htmlgen-1.2.35.20040804.ebuild,v 1.1 2004/08/07 05:22:07 mkennedy Exp $
+
+inherit common-lisp
+
+MY_PV=${PV:0:6}
+CVS_PV=${PV:7:4}.${PV:11:2}.${PV:13}
+
+DESCRIPTION="Franz's library for generating HTML from Common Lisp programs"
+HOMEPAGE="http://packages.debian.org/unstable/web/cl-htmlgen.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-portable-aserve/cl-portable-aserve_${MY_PV}+cvs.${CVS_PV}.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp
+ =dev-lisp/cl-acl-compat-${PV}"
+
+CLPACKAGE=htmlgen
+
+S=${WORKDIR}/cl-portable-aserve-${MY_PV}+cvs.${CVS_PV}
+
+src_install() {
+ common-lisp-install aserve/htmlgen/*.cl aserve/htmlgen/*.asd
+ common-lisp-system-symlink
+ do-debian-credits
+ dodoc ChangeLog
+}