summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-xmls/cl-xmls-1.1.ebuild')
-rw-r--r--dev-lisp/cl-xmls/cl-xmls-1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-lisp/cl-xmls/cl-xmls-1.1.ebuild b/dev-lisp/cl-xmls/cl-xmls-1.1.ebuild
new file mode 100644
index 000000000000..5713cca5f234
--- /dev/null
+++ b/dev-lisp/cl-xmls/cl-xmls-1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-xmls/cl-xmls-1.1.ebuild,v 1.1 2004/08/07 05:22:07 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="XMLS is a small, simple, non-validating XML parser for Common Lisp."
+HOMEPAGE="http://www.common-lisp.net/project/xmls/
+ http://www.cliki.net/xmls"
+SRC_URI="http://www.common-lisp.net/project/xmls/xmls-${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=xmls
+
+S=${WORKDIR}/xmls-${PV}
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dodoc Changelog COPYING
+ dohtml README.html
+ cp -r tests ${D}/usr/share/doc/${P}/
+ dodoc run-tests.sh
+}