summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/sbcl-mt/sbcl-mt-0.8.4.20.ebuild')
-rw-r--r--dev-lisp/sbcl-mt/sbcl-mt-0.8.4.20.ebuild24
1 files changed, 16 insertions, 8 deletions
diff --git a/dev-lisp/sbcl-mt/sbcl-mt-0.8.4.20.ebuild b/dev-lisp/sbcl-mt/sbcl-mt-0.8.4.20.ebuild
index 25947d8767d0..619cea793a48 100644
--- a/dev-lisp/sbcl-mt/sbcl-mt-0.8.4.20.ebuild
+++ b/dev-lisp/sbcl-mt/sbcl-mt-0.8.4.20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl-mt/sbcl-mt-0.8.4.20.ebuild,v 1.1 2003/10/16 20:49:51 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl-mt/sbcl-mt-0.8.4.20.ebuild,v 1.2 2003/10/22 19:53:13 mkennedy Exp $
inherit common-lisp-common
@@ -74,8 +74,8 @@ src_install() {
# doman debian/sbcl-asdf-install.1
use doc && dohtml doc/html/*
- dodoc BUGS COPYING CREDITS INSTALL NEWS OPTIMIZATIONS PRINCIPLES README STYLE TLA TODO
-
+ dodoc BUGS COPYING CREDITS INSTALL NEWS OPTIMIZATIONS PRINCIPLES \
+ README STYLE TLA TODO
do-debian-credits
find ${D} -type f -name .cvsignore -exec rm -f '{}' \;
@@ -86,24 +86,32 @@ src_install() {
# than their .lisp source.
dodir /usr/share/sbcl-mt
- tar cpvzf ${D}/usr/share/sbcl-mt/portage-timestamp-compensate -C ${D}/usr/lib/sbcl-mt .
+ tar cpvzf ${D}/usr/share/sbcl-mt/portage-timestamp-compensate \
+ -C ${D}/usr/lib/sbcl-mt .
}
pkg_postinst() {
tar xvpzf /usr/share/sbcl-mt/portage-timestamp-compensate -C /usr/lib/sbcl-mt
+ # force existing CLC-managed sources to re-compile (possibly unnecessary)
rm -rf /usr/lib/common-lisp/sbcl-mt/* &>/dev/null || true
/usr/bin/clc-autobuild-impl sbcl-mt yes
/usr/sbin/register-common-lisp-implementation sbcl-mt
}
-pkg_prerm() {
- /usr/sbin/unregister-common-lisp-implementation sbcl-mt
-}
+# we do the clean up in postrm since the existence of /usr/bin/scbl-mt
+# in postrm implies that we're doing an upgrade and DONT want our new
+# version unreigistered.
+
+# pkg_prerm() {
+# /usr/sbin/unregister-common-lisp-implementation sbcl-mt
+# }
pkg_postrm() {
# Since we keep our own time stamps we must manually remove them
# here.
if [ ! -x /usr/bin/sbcl-mt ]; then
- rm -rf /usr/lib/sbcl-mt
+ rm -rf /usr/lib/sbcl-mt || true
+ einfo "Unregistering Common Lisp implementation ${PN}"
+ rm -f /usr/lib/common-lisp/bin/${PN}.sh || die
fi
}