summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-expat')
-rw-r--r--dev-ml/ocaml-expat/ChangeLog8
-rw-r--r--dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild24
2 files changed, 13 insertions, 19 deletions
diff --git a/dev-ml/ocaml-expat/ChangeLog b/dev-ml/ocaml-expat/ChangeLog
index 9bb9a6c487b7..c8d9aada5a2d 100644
--- a/dev-ml/ocaml-expat/ChangeLog
+++ b/dev-ml/ocaml-expat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/ocaml-expat
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-expat/ChangeLog,v 1.4 2008/07/13 06:56:01 josejx Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-expat/ChangeLog,v 1.5 2009/09/28 16:53:50 betelgeuse Exp $
+
+ 28 Sep 2009; Petteri Räty <betelgeuse@gentoo.org>
+ ocaml-expat-0.9.1.ebuild:
+ Migrate to EAPI 2 in order to nuke built_with_use.
13 Jul 2008; Joseph Jezak <josejx@gentoo.org> ocaml-expat-0.9.1.ebuild:
Marked ~ppc for bug #197363.
diff --git a/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild b/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild
index ed7269011c97..d14debb42c3b 100644
--- a/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild
+++ b/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild,v 1.4 2008/07/13 06:56:01 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild,v 1.5 2009/09/28 16:53:50 betelgeuse Exp $
-EAPI="1"
+EAPI="2"
inherit findlib eutils
@@ -12,7 +12,8 @@ DESCRIPTION="OCaml bindings for expat"
SRC_URI="http://www.xs4all.nl/~mmzeeman/ocaml/${P}.tar.gz"
HOMEPAGE="http://www.xs4all.nl/~mmzeeman/ocaml/"
-RDEPEND="dev-libs/expat"
+RDEPEND="dev-libs/expat
+ >=dev-lang/ocaml-3.10.2[ocamlopt?]"
DEPEND="${RDEPEND}
test? ( dev-ml/ounit )"
@@ -21,18 +22,7 @@ SLOT="0"
LICENSE="MIT"
KEYWORDS="~amd64 ~ppc ~x86"
-pkg_setup() {
- if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "In order to build ${PN} with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
-
-src_unpack(){
- unpack ${A}
- cd "${S}"
+src_prepare(){
epatch "${FILESDIR}/${P}-test.patch"
}
@@ -57,5 +47,5 @@ src_install() {
if use doc ; then
dohtml -r doc/html/*
fi
- dodoc README
+ dodoc README || die
}