summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/HTML-Mason')
-rw-r--r--dev-perl/HTML-Mason/ChangeLog8
-rw-r--r--dev-perl/HTML-Mason/HTML-Mason-1.33.ebuild63
-rw-r--r--dev-perl/HTML-Mason/files/digest-HTML-Mason-1.333
3 files changed, 73 insertions, 1 deletions
diff --git a/dev-perl/HTML-Mason/ChangeLog b/dev-perl/HTML-Mason/ChangeLog
index dae154ea7a99..59ec5f4e28cd 100644
--- a/dev-perl/HTML-Mason/ChangeLog
+++ b/dev-perl/HTML-Mason/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/HTML-Mason
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.50 2006/06/06 00:35:49 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.51 2006/06/24 17:07:19 mcummings Exp $
+
+*HTML-Mason-1.33 (24 Jun 2006)
+
+ 24 Jun 2006; Michael Cummings <mcummings@gentoo.org>
+ +HTML-Mason-1.33.ebuild:
+ Version bump upstream
06 Jun 2006; <mcummings@gentoo.org> HTML-Mason-1.26.ebuild,
HTML-Mason-1.32.ebuild:
diff --git a/dev-perl/HTML-Mason/HTML-Mason-1.33.ebuild b/dev-perl/HTML-Mason/HTML-Mason-1.33.ebuild
new file mode 100644
index 000000000000..36820e18f6da
--- /dev/null
+++ b/dev-perl/HTML-Mason/HTML-Mason-1.33.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/HTML-Mason-1.33.ebuild,v 1.1 2006/06/24 17:07:19 mcummings Exp $
+
+inherit perl-module
+
+DESCRIPTION="A HTML development and delivery Perl Module"
+SRC_URI="mirror://cpan/authors/id/D/DR/DROLSKY/${P}.tar.gz"
+HOMEPAGE="http://www.masonhq.com/"
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="apache2 modperl doc"
+SRC_TEST="do"
+
+DEPEND="
+ !modperl? ( virtual/perl-CGI )
+ modperl? (
+ !apache2? (
+ =net-www/apache-1*
+ >=www-apache/libapreq-1.0-r2
+ <www-apache/mod_perl-2 )
+ apache2? (
+ >=net-www/apache-2
+ www-apache/libapreq2
+ >=www-apache/mod_perl-2 )
+ )
+ >=dev-perl/Params-Validate-0.7
+ dev-perl/module-build
+ >=dev-perl/Class-Container-0.08
+ >=dev-perl/Exception-Class-1.15
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-File-Spec
+ >=dev-perl/Cache-Cache-1.01"
+
+RDEPEND="${DEPEND}"
+
+mydoc="CREDITS UPGRADE"
+myconf="--noprompts"
+
+perl-module_src_prep() {
+ # Note about new modperl use flag
+ if use !modperl ; then
+ ewarn "HTML-Mason will only install with modperl support"
+ ewarn "if the use flag modperl is enabled."
+ sleep 5
+ fi
+ # rendhalver - needed to set an env var for the build script so it finds our apache.
+ if use apache2; then
+ APACHE="/usr/sbin/apache2"
+ else
+ APACHE="/usr/sbin/apache"
+ fi
+
+ APACHE="${APACHE}" perl ${S}/Build.PL installdirs=vendor destdir=${D} ${myconf}
+}
+
+src_install () {
+ perl-module_src_install
+ # rendhalver - the html docs have subdirs so this gets all of them
+ use doc && dohtml -r htdocs/*
+}
diff --git a/dev-perl/HTML-Mason/files/digest-HTML-Mason-1.33 b/dev-perl/HTML-Mason/files/digest-HTML-Mason-1.33
new file mode 100644
index 000000000000..1ed8e332d09e
--- /dev/null
+++ b/dev-perl/HTML-Mason/files/digest-HTML-Mason-1.33
@@ -0,0 +1,3 @@
+MD5 22c2cd76ed068630708175d570f97277 HTML-Mason-1.33.tar.gz 383225
+RMD160 6143709c72b03c1148c089abb19e1eb0189aa6f1 HTML-Mason-1.33.tar.gz 383225
+SHA256 78605ea4ae0a874538cddb8778b8f243d548e512decf6d95b146e0252690361d HTML-Mason-1.33.tar.gz 383225