summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/PerlQt/PerlQt-3.008-r1.ebuild')
-rw-r--r--dev-perl/PerlQt/PerlQt-3.008-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-perl/PerlQt/PerlQt-3.008-r1.ebuild b/dev-perl/PerlQt/PerlQt-3.008-r1.ebuild
new file mode 100644
index 000000000000..14e44e13a64f
--- /dev/null
+++ b/dev-perl/PerlQt/PerlQt-3.008-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PerlQt/PerlQt-3.008-r1.ebuild,v 1.1 2004/10/02 23:52:53 mcummings Exp $
+
+inherit perl-module kde-base
+
+#install pqtsh to this directory
+myinst="${myinst} INSTBINDIR=${D}/usr/bin"
+myconf="--prefix=${D}/usr --enable-smoke --disable-libtool-lock"
+mydoc="ChangeLog README TODO INSTALL COPYING AUTHORS"
+
+DESCRIPTION="Perl bindings for the Qt 3.x toolkit"
+HOMEPAGE="http://perlqt.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/perlqt/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~sparc"
+IUSE=""
+
+#if kdebindings is installed compilation is really fast!
+# because libsmoke comes with kdebindings-3.1
+
+DEPEND=">=x11-libs/qt-3.0.0"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/PerlQt
+ cp Makefile.PL.in Makefile.PL.in.orig
+ perl -pi -e "s#WriteMakefile\(#WriteMakefile\(\n'PREFIX' => '${D}/usr',#" Makefile.PL.in
+ cd ${S}
+}
+
+src_compile() {
+ addwrite $QTDIR/etc/settings
+ perl-module_src_prep
+}
+
+src_install() {
+
+ addwrite $QTDIR/etc/settings
+ dodir /lib
+ perl-module_src_install
+
+ mkdir -p ${D}/usr/share/doc/${P}/tutorials
+ cp -r ${S}/PerlQt/tutorials/* ${D}/usr/share/doc/${P}/tutorials
+
+ for file in `find ${D}/usr/share/doc/${P}/tutorials/*/*.pl`;do
+ perl -pi -e "s/use blib;/#use blib;/" ${file}
+ chmod +x ${file}
+ done
+
+ mkdir -p ${D}/usr/share/doc/${P}/examples
+ cp -r ${S}/PerlQt/examples/* ${D}/usr/share/doc/${P}/examples
+ for file in `find ${D}/usr/share/doc/${P}/examples/*/*.pl`;do
+ chmod +x ${file}
+ done
+}
+
+