summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php4/pecl-memcache/pecl-memcache-2.0.4.ebuild')
-rw-r--r--dev-php4/pecl-memcache/pecl-memcache-2.0.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-php4/pecl-memcache/pecl-memcache-2.0.4.ebuild b/dev-php4/pecl-memcache/pecl-memcache-2.0.4.ebuild
new file mode 100644
index 000000000000..220efb183ca4
--- /dev/null
+++ b/dev-php4/pecl-memcache/pecl-memcache-2.0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-memcache/pecl-memcache-2.0.4.ebuild,v 1.1 2006/07/02 02:49:07 robbat2 Exp $
+
+PHP_EXT_NAME="memcache"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-pecl-r1
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+DESCRIPTION="PHP extension for using memcached."
+LICENSE="PHP"
+SLOT="0"
+IUSE=""
+
+DEPEND="${DEPEND}
+ sys-libs/zlib"
+
+need_php_by_category
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # fix bug #117990 better, without using a patch
+ # upstream has the file with CRLF instead of LF
+ edos2unix "${S}/config.m4"
+}
+
+src_compile() {
+ has_php
+
+ my_conf="--enable-memcache --with-zlib-dir=/usr"
+ php-ext-pecl-r1_src_compile
+}